码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 1700 Crossing River(贪心)

时间:2015-05-09 10:16:41      阅读:111      评论:0      收藏:0      [点我收藏+]

标签:贪心

V - Crossing River
Time Limit:1000MS     Memory Limit:10000KB     64bit IO Format:%I64d & %I64u

Description

A group of N people wishes to go across a river with only one boat, which can at most carry two persons. Therefore some sort of shuttle arrangement must be arranged in order to row the boat back and forth so that all people may cross. Each person has a different rowing speed; the speed of a couple is determined by the speed of the slower one. Your job is to determine a strategy that minimizes the time for these people to get across.

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. The first line of each case contains N, and the second line contains N integers giving the time for each people to cross the river. Each case is preceded by a blank line. There won‘t be more than 1000 people and nobody takes more than 100 seconds to cross.

Output

For each test case, print a line containing the total number of seconds required for all the N people to cross the river.

Sample Input

1
4
1 2 5 10

Sample Output

17


#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
#include<stack>
#include<vector>
#include<set>
#include<map>

#define L(x) (x<<1)
#define R(x) (x<<1|1)
#define MID(x,y) ((x+y)>>1)

#define eps 1e-8
typedef __int64 ll;

#define fre(i,a,b)  for(i = a; i < b; i++)
#define free(i,b,a) for(i = b; i >= a;i--)
#define mem(t, v)   memset ((t) , v, sizeof(t))
#define ssf(n)      scanf("%s", n)
#define sf(n)       scanf("%d", &n)
#define sff(a,b)    scanf("%d %d", &a, &b)
#define sfff(a,b,c) scanf("%d %d %d", &a, &b, &c)
#define pf          printf
#define bug         pf("Hi\n")

using namespace std;

#define INF 0x3f3f3f3f
#define N  5005

int a[N],n;

int main()
{
	int i,j,t;
	sf(t);
	while(t--)
	{
		scanf("%d",&n);
		for(i=0;i<n;i++)
			sf(a[i]);
		if(n==1)
		{
			pf("%d\n",a[0]);
			continue;
		}
		int ans=0;
		sort(a,a+n);
		int e=n-1;
		while(1)
		{
			if(e==1)
			{
				ans+=max(a[0],a[1]);    //两个人
				break;
			}
            if(e==2)
			{
				ans+=a[0]+a[1]+a[2];   //三个人
				break;
			}
			//送最慢两个人过河
			ans+=min(a[e]+a[0]+a[e-1]+a[0],a[1]+a[e]+a[0]+a[1]);   //0 e 去 0回  0 e-1  去,0回
			e-=2;                                                  //0 1 去,0回,e,e-1去,1回
		}
        pf("%d\n",ans);
	}
  return 0;
}








POJ 1700 Crossing River(贪心)

标签:贪心

原文地址:http://blog.csdn.net/u014737310/article/details/45598909

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!