码迷,mamicode.com
首页 > 其他好文 > 详细

1040. Longest Symmetric String (25)

时间:2015-05-10 06:22:13      阅读:218      评论:0      收藏:0      [点我收藏+]

标签:c++   pat   

Given a string, you are supposed to output the length of the longest symmetric sub-string. For example, given "Is PAT&TAP symmetric?", the longest symmetric sub-string is "s PAT&TAP s", hence you must output 11.

Input Specification:

Each input file contains one test case which gives a non-empty string of length no more than 1000.

Output Specification:

For each test case, simply print the maximum length in a line.

Sample Input:
Is PAT&TAP symmetric?
Sample Output:

11


#include <iostream>
#include <string.h>
using namespace std;

char s[1001];
int main() {
    int i, j, x ,y;
    while(gets(s)) {
        int max  = 0;
        for(i=0; i<strlen(s); i++) {
            for(j=0; i-j >= 0 && i+j < strlen(s); j++) { //奇数时
                if(s[i-j] != s[i+j])
                    break;
                if(j * 2 + 1 > max) {
                    max = j * 2 + 1;
                }
            }
            for(j=0; i-j >= 0 && i+j+1 < strlen(s); j++) {//偶数时
                if(s[i-j] != s[i+j+1])
                    break;
                if(j * 2 + 2 > max) {
                    max = j * 2 + 2;
                }
            }
        }
        cout<<max<<endl;
    }
    return 0;
}


1040. Longest Symmetric String (25)

标签:c++   pat   

原文地址:http://blog.csdn.net/jason_wang1989/article/details/45612777

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!