码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 2151 Check the difficulty of problems(概率dp啊)

时间:2015-05-10 11:26:16      阅读:116      评论:0      收藏:0      [点我收藏+]

标签:dp   poj   

题目链接:http://poj.org/problem?id=2151


Description

Organizing a programming contest is not an easy job. To avoid making the problems too difficult, the organizer usually expect the contest result satisfy the following two terms: 
1. All of the teams solve at least one problem. 
2. The champion (One of those teams that solve the most problems) solves at least a certain number of problems. 

Now the organizer has studied out the contest problems, and through the result of preliminary contest, the organizer can estimate the probability that a certain team can successfully solve a certain problem. 

Given the number of contest problems M, the number of teams T, and the number of problems N that the organizer expect the champion solve at least. We also assume that team i solves problem j with the probability Pij (1 <= i <= T, 1<= j <= M). Well, can you calculate the probability that all of the teams solve at least one problem, and at the same time the champion team solves at least N problems? 

Input

The input consists of several test cases. The first line of each test case contains three integers M (0 < M <= 30), T (1 < T <= 1000) and N (0 < N <= M). Each of the following T lines contains M floating-point numbers in the range of [0,1]. In these T lines, the j-th number in the i-th line is just Pij. A test case of M = T = N = 0 indicates the end of input, and should not be processed.

Output

For each test case, please output the answer in a separate line. The result should be rounded to three digits after the decimal point.

Sample Input

2 2 2
0.9 0.9
1 0.9
0 0 0

Sample Output

0.972

Source

POJ Monthly,鲁小石

题意:

一共有 M 道题, T 个队伍,给出每个队伍做对每道题的概率,

求每个队伍最少做出来一道题和冠军至少做出 N 道题的概率!

代码如下:

#include <cstdio>
#include <cstring>
double p[1017][32];
//p[i][j]:第i支队伍做对第j道题的概率
double dp[1017][32][32];
//dp[i][j][k]:第i支队伍,前j道题中解决了k道题的概率
int main()
{
    int M, T, N;
    while(~scanf("%d%d%d",&M,&T,&N))
    {
        if(M==0 && T==0 && N==0)
        {
            break;
        }
        memset(dp,0,sizeof(dp));
        for(int i = 1; i <= T; i++)
        {
            for(int j = 1; j <= M; j++)
            {
                scanf("%lf",&p[i][j]);
            }
        }
        for(int i = 1; i <= T; i++)
        {
            dp[i][0][0] = 1;
            for(int j = 1; j <= M; j++)
            {
                dp[i][j][0] += dp[i][j-1][0]*(1-p[i][j]);
                for(int k = 1; k <= j; k++)
                {
                    dp[i][j][k] = dp[i][j-1][k-1]*p[i][j]+dp[i][j-1][k]*(1-p[i][j]);
                }
            }
        }
        double ans1 = 1, ans2 = 1;
        for(int i = 1; i <= T; i++)
        {
            ans1*=(1-dp[i][M][0]);//至少做对一道
        }
        double ans = 0;
        for(int i = 1; i <= T; i++)
        {
            double tt = 0;
            for(int k = 1; k <= N-1; k++)//只做对1~N-1道
            {
                tt+=dp[i][M][k];
            }
            ans2*=tt;
        }
        ans = ans1 - ans2;
        printf("%.3lf\n",ans);
    }
    return 0;
}


POJ 2151 Check the difficulty of problems(概率dp啊)

标签:dp   poj   

原文地址:http://blog.csdn.net/u012860063/article/details/45618709

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!