码迷,mamicode.com
首页 > 其他好文 > 详细

hdu1712---ACboy needs your help(dp,分组背包)

时间:2015-05-10 15:49:01      阅读:206      评论:0      收藏:0      [点我收藏+]

标签:dp

Problem Description
ACboy has N courses this term, and he plans to spend at most M days on study.Of course,the profit he will gain from different course depending on the days he spend on it.How to arrange the M days for the N courses to maximize the profit?

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers N and M, N is the number of courses, M is the days ACboy has.
Next follow a matrix A[i][j], (1<=i<=N<=100,1<=j<=M<=100).A[i][j] indicates if ACboy spend j days on ith course he will get profit of value A[i][j].
N = 0 and M = 0 ends the input.

Output
For each data set, your program should output a line which contains the number of the max profit ACboy will gain.

Sample Input

2 2
1 2
1 3
2 2
2 1
2 1
2 3
3 2 1
3 2 1
0 0

Sample Output

3
4
6

Source
HDU 2007-Spring Programming Contest

Recommend
lcy | We have carefully selected several similar problems for you: 3033 2639 2844 2415 3535

显然的分组背包问题
dp[i][j] 表示 前i门课共花的时间<=j时,可以获得的最多的价值
转移即可
当然状态可以优化到一维
循环顺序不能错

/*************************************************************************
    > File Name: hdu1712.cpp
    > Author: ALex
    > Mail: zchao1995@gmail.com 
    > Created Time: 2015年05月10日 星期日 13时52分46秒
 ************************************************************************/

#include <functional>
#include <algorithm>
#include <iostream>
#include <fstream>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <cstdlib>
#include <queue>
#include <stack>
#include <map>
#include <bitset>
#include <set>
#include <vector>

using namespace std;

const double pi = acos(-1.0);
const int inf = 0x3f3f3f3f;
const double eps = 1e-15;
typedef long long LL;
typedef pair <int, int> PLL;

int val[110][110];
int dp[110];

int main() {
    int n, m;
    while (~scanf("%d%d", &n, &m)) {
        if (!n && !m) {
            break;
        }
        for (int i = 1; i <= n; ++i) {
            for (int j = 1; j <= m; ++j) {
                scanf("%d", &val[i][j]);
            }
        }
        memset(dp, 0, sizeof(dp));
        for (int i = 1; i <= n; ++i) {
            for (int j = m; j >= 0; --j) {
                for (int k = 1; k <= m; ++k) {
                    if (j >= k && dp[j - k] != -inf) {
                        dp[j] = max(dp[j], dp[j - k] + val[i][k]);
                    }
                }
            }
        }
        printf("%d\n", dp[m]);
    }
    return 0;
}

hdu1712---ACboy needs your help(dp,分组背包)

标签:dp

原文地址:http://blog.csdn.net/guard_mine/article/details/45620503

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!