码迷,mamicode.com
首页 > 其他好文 > 详细

CSU1612: Destroy Tunnels

时间:2015-05-10 20:34:04      阅读:128      评论:0      收藏:0      [点我收藏+]

标签:csu

Description

Zuosige always has bad luck. Recently, he is in hospital because of pneumonia. While he is taking his injection, he feels extremely bored. However, clever Zuosige comes up with a new game.

Zuosige is playing a computer game called Call of Pneumonia. In the game, Zuosige is pursued by germs which may cause pneumonia. Zuosige is feared, so he wants to destroy the country. The country consists of N cities and for each city, there exits exactly one directed tunnel from it to every other city.

To destroy bridges, Zuosige gets a magic matrix An*n (Ai,j>=0). Then let 技术分享 , if Bi,j>0, the bridge from city i to city j will be destroyed.

Now Zuosige wants to know whether he can destroy all tunnels.

Input

The first line contains one integer T, indicating the number of test cases.
In one test case, there are several lines.
In the first line, there is one integer N (1<=n<=1000), indicating the number of cities.
In the following N lines, each line has N integers. These N lines describes matrix A. The j-th integer in i-th line is Ai,j.

Output

For each test case, output “not exists” if all tunnels can be destroyed or “exists” otherwise.

Sample Input

2
3
0 1 3
2 0 1
1 1 0
3
0 1 0
0 0 0
0 0 0

Sample Output

not exists
exists

HINT

Source


题意:根据题目要求的公式,能不能让矩阵都变成非0

由于数学并非我的强项,其实这道题更多是猜的。。

#include <iostream> 
#include <stdio.h> 
#include <string.h> 
#include <stack> 
#include <queue> 
#include <map> 
#include <set> 
#include <vector> 
#include <math.h> 
#include <bitset> 
#include <algorithm> 
using namespace std; 
#define ls 2*i 
#define rs 2*i+1 
#define up(i,x,y) for(i=x;i<=y;i++) 
#define down(i,x,y) for(i=x;i>=y;i--) 
#define mem(a,x) memset(a,x,sizeof(a)) 
#define w(a) while(a) 
#define LL long long 
const double pi = acos(-1.0); 
#define N 1000005 
#define mod 19999997 
const int INF = 0x3f3f3f3f; 
#define exp 1e-8 
  
bitset<1005> a[1005]; 
  
int main() 
{ 
    int t,n,i,j,k,flag; 
    cin>>t; 
    w(t--) 
    { 
        cin>>n; 
        up(i,1,n) 
        { 
            up(j,1,n) 
            { 
                cin>>k; 
                a[i][j] = (k>0?1:0); 
            } 
        } 
        up(i,1,n) 
        { 
            up(j,1,n) 
            if(a[j][i]) a[j]|=a[i]; 
        } 
        flag = 0; 
        up(i,1,n) 
        { 
            up(j,1,n) 
            { 
                if(i==j)continue; 
                if(!a[i][j]) 
                { 
                    flag=1; 
                    break; 
                } 
            } 
            if(flag) break; 
        } 
        if(flag) printf("exists\n"); 
        else
            printf("not exists\n"); 
    } 
  
    return 0; 
} 


CSU1612: Destroy Tunnels

标签:csu

原文地址:http://blog.csdn.net/libin56842/article/details/45624143

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!