码迷,mamicode.com
首页 > 其他好文 > 详细

As Easy As A+B

时间:2015-05-11 09:08:14      阅读:123      评论:0      收藏:0      [点我收藏+]

标签:acm

As Easy As A+B

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2882 Accepted Submission(s): 1357

Problem Description
These days, I am thinking about a question, how can I get a problem as easy as A+B? It is fairly difficulty to do such a thing. Of course, I got it after many waking nights.
Give you some integers, your task is to sort these number ascending (升序).
You should know how easy the problem is now!
Good luck!
 

Input
Input contains multiple test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow. Each test case contains an integer N (1<=N<=1000 the number of integers to be sorted) and then N integers follow in the same line. 
It is guarantied that all integers are in the range of 32-int.
 

Output
For each case, print the sorting result, and one line one case.
 

Sample Input
2
3 2 1 3
9 1 4 7 2 5 8 3 6 9
 

Sample Output
1 2 3
1 2 3 4 5 6 7 8 9
 

Author
lcy

很简单的一道题,只要注意一下格式就OK了。

#include<stdio.h>
#include<stdlib.h>

int cmp(const void *a,const void *b)
{
    return *(int *)a - *(int *)b;//由小到大排序
}

int main()
{
    int n,m;
    int i;
    int data[1001]={0};

    scanf("%d",&n);
    while(n--)
    {
        scanf("%d",&m);
        for(i=0;i<m;i++)
        {
            scanf("%d",&data[i]);
        }
        qsort(data,m,sizeof(int),cmp);
        for(i=0;i<m-1;i++)
        {
            printf("%d ",data[i]);
        }
         printf("%d\n",data[i]);
    }
    return 0;
}



As Easy As A+B

标签:acm

原文地址:http://blog.csdn.net/u010275850/article/details/45623729

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!