码迷,mamicode.com
首页 > 其他好文 > 详细

解题报告 之 POJ2769 Reduced ID Numbers

时间:2015-05-11 13:01:31      阅读:129      评论:0      收藏:0      [点我收藏+]

标签:poj2769   reduced id numbers   数论   同余   acm   

解题报告 之 POJ2769 Reduced ID Numbers


Description
T. Chur teaches various groups of students at university U. Every U-student has a unique Student Identification Number (SIN). A SIN s is an integer in the range 0 ≤ s ≤ MaxSIN with MaxSIN = 10 6-1. T. Chur finds this range of SINs too large for identification within her groups. For each group, she wants to find the smallest positive integer m, such that within the group all SINs reduced modulo m are unique.

Input

On the first line of the input is a single positive integer N, telling the number of test cases (groups) to follow. Each case starts with one line containing the integer G (1 ≤ G ≤ 300): the number of students in the group. The following G lines each contain one SIN. The SINs within a group are distinct, though not necessarily sorted.

Output

For each test case, output one line containing the smallest modulus m, such that all SINs reduced modulo m are distinct.

Sample Input

2
1
124866
3
124866
111111
987651

Sample Output

1
8


题目大意:给定一些不超过1e6的数字,让你找一个最小的数k,使得给出的数中没有任何两个数对k同余。


分析:解题思路是十分朴素的实验法。直接从1开始试每个数字看看有没有同余的,如果找到同余则break,直到找到一个合适的数为止。但是有一个问题是在C++上超时但在G++上却AC了,不知道其中的奥妙何在,求大神提点。


上代码:

#include<iostream>
#include<algorithm>
#include<cmath>
#include<map>
#include<cstring>
using namespace std;

const int MAXN = 1e5+10;
const int MAXM = 1e6 + 10;

int stu[MAXN];
int m[MAXN];

int main()
{
	int kase;
	cin >> kase;
	while(kase--)
	{
		//memset( mod, 0, sizeof mod );
		int n;

		cin >> n;
		for(int i = 1; i <= n; i++)
			cin >> stu[i];
		
		bool flag;
		int i;
		for(i = 1; ; i++)
		{
			memset( m, 0, sizeof m );
			flag = true;
			for(int j = 1; j <= n; j++)
			{
				if(m[stu[j] % i] == 1)
				{
					flag = false;
					break;
				}
				else
					m[stu[j] % i] = 1;
			}
			if(flag)break;
		}
		cout << i << endl;
	}
	return 0;
}

嗯,开始了同余方程。


解题报告 之 POJ2769 Reduced ID Numbers

标签:poj2769   reduced id numbers   数论   同余   acm   

原文地址:http://blog.csdn.net/maxichu/article/details/45642653

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!