码迷,mamicode.com
首页 > 其他好文 > 详细

解题报告 之 POJ1021 Fibonacci Again

时间:2015-05-11 14:58:00      阅读:137      评论:0      收藏:0      [点我收藏+]

标签:poj1021   fibonacci again   数论   同余   

解题报告 之 POJ1021 Fibonacci Again


Description

There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2). 
 

Input

Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000). 
 

Output

Print the word "yes" if 3 divide evenly into F(n). 

Print the word "no" if not. 
 

Sample Input

0 1 2 3 4 5
 

Sample Output

no no yes no no no
 


题目大意:设新的斐波那契数列f(0)=7,f(1)=11, f(n)=f(n-1)+f(n-2),(n>=2)。输入n,判断f(n)是否能被3整除。

分析:首先明确是不可能直接加起来再求余数的。根据同余的基本性质,a=b+c,则a ≡ b+c (mod m),即可以转移取模的顺序,有:

f(n) ≡ f(n-1)+f(n-2) (mod m)

然后我们打表对f(n)取模3,依次处理下去即可。


上代码:

#include<iostream>
#include<algorithm>
using namespace std;

const int MAXN = 1e6 + 10;

int remain[MAXN];

void solve()
{
	remain[0] = 7 % 3; 
	remain[1] = 11 % 3;
	for(int i = 2; i < MAXN; i++)
		remain[i] = (remain[i - 1] + remain[i - 2]) % 3;
}

int main()
{
	int n;
	solve();
	while(cin >> n)
	{
		cout << (remain[n] == 0? "yes":"no") << endl;
	}
	return 0;
}

还有种更加诡异和巧妙的方法。就是打表过程中你会发现,余数的变化是1 2 0 2 2 1 0 1 || 1 2 0 2 2 1 0 1 ……,出现了循环节8,那么我们可以直接判断n%8+1是否等于3或者7。省去了打表的时间。


上代码:

#include<cstdio>
using namespace std;
int main()
{
	int n;
	while(scanf( "%d", &n ) == 1)
		printf( "%s\n", (n % 8 == 2 || n % 8 == 6) ? "yes" : "no" );
	return 0;
}


就这样一道水题飘过。

解题报告 之 POJ1021 Fibonacci Again

标签:poj1021   fibonacci again   数论   同余   

原文地址:http://blog.csdn.net/maxichu/article/details/45642741

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!