码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 5078 Osu!

时间:2015-05-12 09:28:50      阅读:176      评论:0      收藏:0      [点我收藏+]

标签:hdu   最水题   入门   

题目链接:hdu 5078 Osu!


题面:


Osu!

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 1058    Accepted Submission(s): 550
Special Judge


Problem Description
Osu! is a very popular music game. Basically, it is a game about clicking. Some points will appear on the screen at some time, and you have to click them at a correct time.

技术分享

Now, you want to write an algorithm to estimate how diffecult a game is.

To simplify the things, in a game consisting of N points, point i will occur at time ti at place (xi, yi), and you should click it exactly at ti at (xi, yi). That means you should move your cursor from point i to point i+1. This movement is called a jump, and the difficulty of a jump is just the distance between point i and point i+1 divided by the time between ti and ti+1. And the difficulty of a game is simply the difficulty of the most difficult jump in the game.

Now, given a description of a game, please calculate its difficulty.
 

Input
The first line contains an integer T (T ≤ 10), denoting the number of the test cases.

For each test case, the first line contains an integer N (2 ≤ N ≤ 1000) denoting the number of the points in the game.  Then N lines follow, the i-th line consisting of 3 space-separated integers, ti(0 ≤ ti < ti+1 ≤ 106), xi, and yi (0 ≤ xi, yi ≤ 106) as mentioned above.
 

Output
For each test case, output the answer in one line.

Your answer will be considered correct if and only if its absolute or relative error is less than 1e-9.
 

Sample Input
2 5 2 1 9 3 7 2 5 9 0 6 6 3 7 6 0 10 11 35 67 23 2 29 29 58 22 30 67 69 36 56 93 62 42 11 67 73 29 68 19 21 72 37 84 82 24 98
 

Sample Output
9.2195444573 54.5893762558
Hint
In memory of the best osu! player ever Cookiezi.
 

Source
 


题意:就求最大值,开始还以为贪心,直接暴力就好了。


代码:

#include <iostream>
#include <iomanip>
#include <cmath>
using namespace std;
long long int squared_dis(long long int x1,long long int y3,long long int x2,long long int y2)
{
	return (x1-x2)*(x1-x2)+(y3-y2)*(y3-y2);
}
long long int store_x[1005],store_y[1005],t[1005];
int main()
{
	int tt,n;
	cin>>tt;
	while(tt--)
	{
		double maxx=0;
	  cin>>n;
	  double tmp;
	  for(int i=0;i<n;i++)
	  {
  	    cin>>t[i]>>store_x[i]>>store_y[i];	
  	  }	
  	  for(int i=0;i<n-1;i++)
  	  {
  	  	for(int j=i+1;j<n;j++)
  	  	{
  	  		if(t[i]!=t[j])
  	  		tmp=sqrt(1.0*squared_dis(store_x[i],store_y[i],store_x[j],store_y[j]))/abs(t[i]-t[j]);
	  	  	if(tmp>maxx)
	  	  	maxx=tmp;
	     }
  	  }
  	  cout<<fixed<<setprecision(10)<<maxx<<endl;
	}
	return 0;
} 


HDU 5078 Osu!

标签:hdu   最水题   入门   

原文地址:http://blog.csdn.net/david_jett/article/details/45652071

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!