码迷,mamicode.com
首页 > 其他好文 > 详细

【POJ2386】Lake Counting

时间:2015-05-12 09:32:58      阅读:120      评论:0      收藏:0      [点我收藏+]

标签:

Lake Counting
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 22736   Accepted: 11457

Description

Due to recent rains, water has pooled in various places in Farmer John‘s field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water (‘W‘) or dry land (‘.‘). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors.

Given a diagram of Farmer John‘s field, determine how many ponds he has.

Input

* Line 1: Two space-separated integers: N and M

* Lines 2..N+1: M characters per line representing one row of Farmer John‘s field. Each character is either ‘W‘ or ‘.‘. The characters do not have spaces between them.

Output

* Line 1: The number of ponds in Farmer John‘s field.

Sample Input

10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.

Sample Output

3

题意:大概就是W的地方是水洼 求有几个水洼 上下左右还有斜线方向都算是连同

题解:深搜求连通区域  搜索过的地方就直接标记成.就好咯       最后进入过几次深搜就有几个水洼


#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;

const int maxn = 110;
int N, M;                   //长宽
char fi[maxn][maxn];        //地图

void dfs(int x, int y);

int main(){
    scanf("%d%d", &N, &M);
    for(int i = 0; i < N; ++i){
        scanf("%s", fi[i]);
    }

    int ans = 0;            //答案
    for(int i = 0; i < N; ++i){
        for(int j = 0; j < M; ++j){
            if(fi[i][j] == 'W'){    //搜索到一个新的W区域
                dfs(i, j);          //进入搜索
                ++ans;              //答案+1
            }
        }
    }

    printf("%d\n", ans);
    return 0;
}

void dfs(int x, int y){
    fi[x][y] = '.';             //搜索过的点标记为.

    for(int dx = -1; dx <= 1; ++dx){        //搜索上下左右斜线方向
        for(int dy = -1; dy <= 1; ++dy){
            int nx = x + dx;
            int ny = y +dy;

            if(0 <= nx && nx < N && 0 <= ny && ny < M && fi[nx][ny] == 'W'){    //符合要求则继续搜索
                dfs(nx, ny);
            }
        }
    }
}


【POJ2386】Lake Counting

标签:

原文地址:http://blog.csdn.net/u012431590/article/details/45649673

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!