码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 4565 So Easy!(矩阵快速幂)

时间:2015-05-12 15:50:15      阅读:136      评论:0      收藏:0      [点我收藏+]

标签:hdu 4565 so easy   矩阵快速幂   

So Easy!

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2777    Accepted Submission(s): 863


Problem Description
  A sequence Sn is defined as:
技术分享

Where a, b, n, m are positive integers.┌x┐is the ceil of x. For example, ┌3.14┐=4. You are to calculate Sn.
  You, a top coder, say: So easy! 
技术分享
 

Input
  There are several test cases, each test case in one line contains four positive integers: a, b, n, m. Where 0< a, m < 215, (a-1)2< b < a2, 0 < b, n < 231.The input will finish with the end of file.
 

Output
  For each the case, output an integer Sn.
 

Sample Input
2 3 1 2013 2 3 2 2013 2 2 1 2013
 

Sample Output
4 14 4
 

Source
 

Recommend
zhoujiaqi2010   |   We have carefully selected several similar problems for you:  5227 5226 5225 5224 5222 
 


看了题解,推公式。

A(n)=[(a+sqrt(b))^n],B(n)=[(a-sqrt(b))^n]

C(n)=A(n);

因为(a-1)2< b < a2,则B(n)属于(0,1);

C(n)=A(n)+B(n);

C(n)*(a+sqrt(b)+a-sqrt(b))=(a+sqrt(b))^(n+1)+(a-sqrt(b))(n+1)+(a*a-b)((a+sqrt(b))^(n-1)+(a-sqrt(b))(n-1));

即:

C(n)*2a=C(n+1)+(a*a-b)*C(n-1);

=>C(n+1)=2a*C(n)-(a*a-b)*C(n-1);


构造矩阵    :mat A(2,vec(2));
                      A[0][0]=2*a%m;
                      A[0][1]=(m-a*a%m+b)%m;
                      A[1][0]=1;
                      A[1][1]=0;

                    C(1)=2*a%m;

                    C(2)=2*(a*a%m+b)%m;

#include<cstdio>
#include<algorithm>
#include<cstring>
#include<iostream>
#include<string>
#include<vector>
#define ll long long

using namespace std;

ll a,b,n,m;
typedef vector<ll>vec;
typedef vector<vec>mat;

mat mul(mat &A,mat &B) {
    mat C(A.size(),vec(B[0].size()));
    for(int i=0; i<A.size(); i++) {
        for(int k=0; k<B.size(); k++) {
            for(int j=0; j<B[0].size(); j++) {
                C[i][j]=(C[i][j]+A[i][k]*B[k][j])%m;
            }
        }
    }
    return C;
}

mat pow_mod(mat A,ll x) {
    mat B(A.size(),vec(A.size()));
    for(int i=0; i<A.size(); i++) {
        B[i][i]=1;
    }
    while(x>0) {
        if(x&1)B=mul(B,A);
        A=mul(A,A);
        x>>=1;
    }
    return B;
}

int main() {
    //freopen("test.in","r",stdin);
    while(~scanf("%I64d%I64d%I64d%I64d",&a,&b,&n,&m)) {
        if(n==1) {
            printf("%I64d\n",2*a%m);
            continue;
        }
        if(n==2) {
            printf("%I64d\n",2*(a*a%m+b)%m);
            continue;
        }
        mat A(2,vec(2));
        A[0][0]=2*a%m;
        A[0][1]=(m-a*a%m+b)%m;
        A[1][0]=1;
        A[1][1]=0;
        A=pow_mod(A,n-2);
        ll ans=(A[0][0]*2*(a*a%m+b)%m+A[0][1]*2*a%m)%m;
        printf("%I64d\n",ans);
    }
    return 0;
}


hdu 4565 So Easy!(矩阵快速幂)

标签:hdu 4565 so easy   矩阵快速幂   

原文地址:http://blog.csdn.net/acm_baihuzi/article/details/45669061

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!