码迷,mamicode.com
首页 > 其他好文 > 详细

UVA 10271 Chopsticks(线性DP)

时间:2015-05-12 23:00:48      阅读:271      评论:0      收藏:0      [点我收藏+]

标签:

In China, people use a pair of chopsticks to get food on the table, but Mr. L is a bit different. He uses
a set of three chopsticks – one pair, plus an EXTRA long chopstick to get some big food by piercing
it through the food. As you may guess, the length of the two shorter chopsticks should be as close as
possible, but the length of the extra one is not important, as long as it’s the longest. To make things
clearer, for the set of chopsticks with lengths A, B, C (A ≤ B ≤ C), (A ? B)
2
is called the “badness”
of the set.
It’s December 2nd, Mr.L’s birthday! He invited K people to join his birthday party, and would like
to introduce his way of using chopsticks. So, he should prepare K + 8 sets of chopsticks(for himself,
his wife, his little son, little daughter, his mother, father, mother-in-law, father-in-law, and K other
guests). But Mr.L suddenly discovered that his chopsticks are of quite different lengths! He should find
a way of composing the K + 8 sets, so that the total badness of all the sets is minimized.
Input
The first line in the input contains a single integer T, indicating the number of test cases (1 ≤ T ≤ 20).
Each test case begins with two integers K, N (0 ≤ K ≤ 1000, 3K + 24 ≤ N ≤ 5000), the number of
guests and the number of chopsticks.
There are N positive integers Li on the next line in non–decreasing order indicating the lengths of
the chopsticks (1 ≤ Li ≤ 32000).
Output
For each test case in the input, print a line containing the minimal total badness of all the sets.
Note: For the sample input, a possible collection of the 9 sets is:
8,10,16; 19,22,27; 61,63,75; 71,72,88; 81,81,84; 96,98,103; 128,129,148; 134,134,139; 157,157,160
Sample Input
1
1 40
1 8 10 16 19 22 27 33 36 40 47 52 56 61 63 71 72 75 81 81 84 88 96 98
103 110 113 118 124 128 129 134 134 139 148 157 157 160 162 164
Sample Output

23

要保证有一根长筷子,我们可以从后到前DP:f[i][j]:前i根配了j对的最小代价。

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<vector>
#include<string>
#include<iostream>
#include<queue>
#include<cmath>
#include<map>
#include<stack>
#include<bitset>
using namespace std;
#define REPF( i , a , b ) for ( int i = a ; i <= b ; ++ i )
#define REP( i , n ) for ( int i = 0 ; i < n ; ++ i )
#define CLEAR( a , x ) memset ( a , x , sizeof a )
typedef long long LL;
typedef pair<int,int>pil;
const int INF = 0x3f3f3f3f;
int t,n,k;
int a[5500];
LL dp[5500][1100];
int main()
{
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&k,&n);
        k+=8;CLEAR(dp,INF);
        for(int i=n;i>=1;i--)
            scanf("%d",&a[i]);
        dp[0][0]=0;
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=k;j++)
            {
                dp[i][j]=dp[i-1][j];
                if(i-j*3>=0)
                    dp[i][j]=min(dp[i][j],dp[i-2][j-1]+(a[i]-a[i-1])*(a[i]-a[i-1]));
            }
        }
        printf("%lld\n",dp[n][k]);
    }
    return 0;
}

NJUPT 1581 

题目描述

A 先生有很多双筷子。确切的说应该是很多根,因为筷子的长度不一,很难判断出哪两根是一双的。这天,A 先生家里来了K 个客人,A 先生留下他们吃晚饭。加上A 先生,A夫人和他们的孩子小A,共K+3个人。每人需要用一双筷子。A 先生只好清理了一下筷子,共N 根,长度为T1,T2,T3,……,TN。现在他想用这些筷子组合成K+3 双,使每双的筷子长度差的平方和最小。(怎么不是和最小??这要去问A 先生了,呵呵)

输入

共有两行,第一行为两个用空格隔开的整数,表示N,K(1≤N≤100,0<K<50),第二行共有N个用空格隔开的整数,为Ti每个整数为1~50之间的数。

输出

仅一行。如果凑不齐K+3双,输出-1,否则输出长度差平方和的最小值。

样例输入

10 1
1 1 2 3 3 3 4 6 10 20

样例输出

5

提示

第一双 1 1
第二双 2 3
第三双 3 3
第四双 4 6
(1-1)^2+(2-3)^2+(3-3)^2+(4-6)^2=5

弱化版,较简单

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<vector>
#include<string>
#include<iostream>
#include<queue>
#include<cmath>
#include<map>
#include<stack>
#include<bitset>
using namespace std;
#define REPF( i , a , b ) for ( int i = a ; i <= b ; ++ i )
#define REP( i , n ) for ( int i = 0 ; i < n ; ++ i )
#define CLEAR( a , x ) memset ( a , x , sizeof a )
typedef long long LL;
typedef pair<int,int>pil;
const int INF = 0x3f3f3f3f;
int dp[110][55];
int L[110];
int n,m;

int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        REPF(i,1,n) scanf("%d",&L[i]);
        sort(L+1,L+n+1);
        m+=3;
        CLEAR(dp,INF);
        dp[0][0]=0;
        for(int i=2;i<=n;i++)
        {
            for(int j=1;j<=m;j++)
                dp[i][j]=min(dp[i-1][j],dp[i-2][j-1]+(L[i-1]-L[i])*(L[i-1]-L[i]));
        }
        if(dp[n][m]!=INF) printf("%d\n",dp[n][m]);
        else puts("-1");
    }
    return 0;
}


/*

*/




UVA 10271 Chopsticks(线性DP)

标签:

原文地址:http://blog.csdn.net/u013582254/article/details/45676769

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!