标签:des style class blog code http
All in All
Time Limit: 1000MS |
|
Memory Limit: 30000K |
Total Submissions: 27352 |
|
Accepted: 11187 |
Description
You have devised a new encryption technique which encodes a message by inserting between its characters randomly generated strings in a clever way. Because of pending patent issues we will not discuss in detail how the strings are generated and inserted into
the original message. To validate your method, however, it is necessary to write a program that checks if the message is really encoded in the final string.
Given two strings s and t, you have to decide whether s is a subsequence of t, i.e. if you can remove characters from t such that the concatenation of the remaining characters is s.
Input
The input contains several testcases. Each is specified by two strings s, t of alphanumeric ASCII characters separated by whitespace.The length of s and t will no more than 100000.
Output
For each test case output "Yes", if s is a subsequence of t,otherwise output "No".
Sample Input
sequence subsequence
person compression
VERDI vivaVittorioEmanueleReDiItalia
caseDoesMatter CaseDoesMatter
Sample Output
Yes
No
Yes
No
Source
解题报告
水一题。。。
#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
using namespace std;
int main()
{
int i,j;
char str1[100010],str2[100010];
while(cin>>str1>>str2)
{
int m=0;
int l1=strlen(str1);
int l2=strlen(str2);
for(i=0;i<l2;i++)
{
if(str2[i]==str1[m])
m++;
if(m==l1)
break;
}
if(m==l1)cout<<"Yes"<<endl;
else cout<<"No"<<endl;
}
return 0;
}
POJ训练计划1936_All in All(串处理),布布扣,bubuko.com
POJ训练计划1936_All in All(串处理)
标签:des style class blog code http
原文地址:http://blog.csdn.net/juncoder/article/details/30290697