码迷,mamicode.com
首页 > 其他好文 > 详细

poj 2247 Humble Numbers

时间:2014-06-15 19:04:15      阅读:159      评论:0      收藏:0      [点我收藏+]

标签:poj   acm   

Humble Numbers
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 9396   Accepted: 4417

Description

A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers.

Write a program to find and print the nth element in this sequence.

Input

The input consists of one or more test cases. Each test case consists of one integer n with 1 <= n <= 5842. Input is terminated by a value of zero (0) for n.

Output

For each test case, print one line saying "The nth humble number is number.". Depending on the value of n, the correct suffix "st", "nd", "rd", or "th" for the ordinal number nth has to be used like it is shown in the sample output.

Sample Input

1
2
3
4
11
12
13
21
22
23
100
1000
5842
0

Sample Output

The 1st humble number is 1.
The 2nd humble number is 2.
The 3rd humble number is 3.
The 4th humble number is 4.
The 11th humble number is 12.
The 12th humble number is 14.
The 13th humble number is 15.
The 21st humble number is 28.
The 22nd humble number is 30.
The 23rd humble number is 32.
The 100th humble number is 450.
The 1000th humble number is 385875.
The 5842nd humble number is 2000000000.

AC代码如下:

#include<iostream>
#include<cstdio>
using namespace std;

int min(int a,int b)
{
    if(a<b)
        return a;
    return b;
}

int main()
{
    int n,f[10005];
    int a,b,c,d;
    int i;
    while(~scanf("%d",&n)&&n)
    {
    f[1]=1;
    a=1;b=1;c=1;d=1;
    for(i=2;i<=n;i++)
    {
        f[i]=min(min(min(f[a]*2,f[b]*3),f[c]*5),f[d]*7);
        if(f[i]==f[a]*2)
            a++;
        if(f[i]==f[b]*3)
            b++;
        if(f[i]==f[c]*5)
            c++;
        if(f[i]==f[d]*7)
            d++;
    }
    if(n%10==1&&n%100!=11)
        printf("The %dst",n);
    else if(n%10==2&&n%100!=12)
        printf("The %dnd",n);
    else if(n%10==3&&n%100!=13)
        printf("The %drd",n);
    else printf("The %dth",n);
    printf(" humble number is %d.\n",f[n]);
    }
    return 0;
}



poj 2247 Humble Numbers,布布扣,bubuko.com

poj 2247 Humble Numbers

标签:poj   acm   

原文地址:http://blog.csdn.net/hanhai768/article/details/30274139

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!