码迷,mamicode.com
首页 > 其他好文 > 详细

Fibbonacci Number

时间:2015-05-13 16:55:46      阅读:105      评论:0      收藏:0      [点我收藏+]

标签:

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 17169    Accepted Submission(s): 8151


Problem Description
Your objective for this question is to develop a program which will generate a fibbonacci number. The fibbonacci function is defined as such:

f(0) = 0
f(1) = 1
f(n) = f(n-1) + f(n-2)

Your program should be able to handle values of n in the range 0 to 50.
 

Input
Each test case consists of one integer n in a single line where 0≤n≤50. The input is terminated by -1.
 

Output
Print out the answer in a single line for each test case.
 

Sample Input
3 4 5 -1
 

Sample Output
2 3 5


#include<stdio.h>

main()
{
    __int64 x[57];
    int i,j,n;
    x[0]=0;
    x[1]=1;
    for(i=2;i<52;i++) 
    x[i]=x[i-1]+x[i-2];
    while(scanf("%d",&n)&&n!=-1)
        {
              printf("%I64d\n",x[n]);                  
                                }
         return 0;                        
      }

Fibbonacci Number

标签:

原文地址:http://blog.csdn.net/l15738519366/article/details/45692793

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!