码迷,mamicode.com
首页 > 其他好文 > 详细

(树的重心) poj 1655

时间:2015-05-13 21:46:04      阅读:154      评论:0      收藏:0      [点我收藏+]

标签:

Balancing Act
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 9965   Accepted: 4087

Description

Consider a tree T with N (1 <= N <= 20,000) nodes numbered 1...N. Deleting any node from the tree yields a forest: a collection of one or more trees. Define the balance of a node to be the size of the largest tree in the forest T created by deleting that node from T. 
For example, consider the tree: 
技术分享

Deleting node 4 yields two trees whose member nodes are {5} and {1,2,3,6,7}. The larger of these two trees has five nodes, thus the balance of node 4 is five. Deleting node 1 yields a forest of three trees of equal size: {2,6}, {3,7}, and {4,5}. Each of these trees has two nodes, so the balance of node 1 is two. 

For each input tree, calculate the node that has the minimum balance. If multiple nodes have equal balance, output the one with the lowest number. 

Input

The first line of input contains a single integer t (1 <= t <= 20), the number of test cases. The first line of each test case contains an integer N (1 <= N <= 20,000), the number of congruence. The next N-1 lines each contains two space-separated node numbers that are the endpoints of an edge in the tree. No edge will be listed twice, and all edges will be listed.

Output

For each test case, print a line containing two integers, the number of the node with minimum balance and the balance of that node.

Sample Input

1
7
2 6
1 2
1 4
4 5
3 7
3 1

Sample Output

1 2

Source

 
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<cstdlib>
#include<string>
#include<vector>
#define INF 100000000
using namespace std;
vector<int> e[20005];
int n,dp[20005],ans,num;
void dfs(int u,int father)
{
    int maxx=0;
    dp[u]=1;
    for(int i=0;i<e[u].size();i++)
    {
        int v=e[u][i];
        if(v==father)
            continue;
        dfs(v,u);
        dp[u]+=dp[v];
        maxx=max(maxx,dp[v]);
    }
    maxx=max(maxx,n-dp[u]);
    if(maxx==ans)
    {
        if(u<num)
            num=u;
    }
    if(maxx<ans)
    {
        ans=maxx;
        num=u;
    }
}
int main()
{
    int tt;
    scanf("%d",&tt);
    while(tt--)
    {
        scanf("%d",&n);
        for(int i=1;i<=n;i++)
            e[i].clear();
        num=1;
        ans=INF;
        for(int i=1;i<n;i++)
        {
            int x,y;
            scanf("%d%d",&x,&y);
            e[x].push_back(y);
            e[y].push_back(x);
        }
        dfs(1,-1);
        printf("%d %d\n",num,ans);
    }
    return 0;
}

  

(树的重心) poj 1655

标签:

原文地址:http://www.cnblogs.com/water-full/p/4501674.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!