码迷,mamicode.com
首页 > 其他好文 > 详细

POJ1037:A decorative fence(DP)

时间:2015-05-13 23:17:20      阅读:299      评论:0      收藏:0      [点我收藏+]

标签:poj

Description

Richard just finished building his new house. Now the only thing the house misses is a cute little wooden fence. He had no idea how to make a wooden fence, so he decided to order one. Somehow he got his hands on the ACME Fence Catalogue 2002, the ultimate resource on cute little wooden fences. After reading its preface he already knew, what makes a little wooden fence cute. 
A wooden fence consists of N wooden planks, placed vertically in a row next to each other. A fence looks cute if and only if the following conditions are met: 
?The planks have different lengths, namely 1, 2, . . . , N plank length units. 
?Each plank with two neighbors is either larger than each of its neighbors or smaller than each of them. (Note that this makes the top of the fence alternately rise and fall.) 
It follows, that we may uniquely describe each cute fence with N planks as a permutation a1, . . . , aN of the numbers 1, . . . ,N such that (any i; 1 < i < N) (ai ? ai?1)*(ai ? ai+1) > 0 and vice versa, each such permutation describes a cute fence. 
It is obvious, that there are many di erent cute wooden fences made of N planks. To bring some order into their catalogue, the sales manager of ACME decided to order them in the following way: Fence A (represented by the permutation a1, . . . , aN) is in the catalogue before fence B (represented by b1, . . . , bN) if and only if there exists such i, that (any j < i) aj = bj and (ai < bi). (Also to decide, which of the two fences is earlier in the catalogue, take their corresponding permutations, find the first place on which they differ and compare the values on this place.) All the cute fences with N planks are numbered (starting from 1) in the order they appear in the catalogue. This number is called their catalogue number. 
技术分享

After carefully examining all the cute little wooden fences, Richard decided to order some of them. For each of them he noted the number of its planks and its catalogue number. Later, as he met his friends, he wanted to show them the fences he ordered, but he lost the catalogue somewhere. The only thing he has got are his notes. Please help him find out, how will his fences look like.

Input

The first line of the input file contains the number K (1 <= K <= 100) of input data sets. K lines follow, each of them describes one input data set. 
Each of the following K lines contains two integers N and C (1 <= N <= 20), separated by a space. N is the number of planks in the fence, C is the catalogue number of the fence. 
You may assume, that the total number of cute little wooden fences with 20 planks fits into a 64-bit signed integer variable (long long in C/C++, int64 in FreePascal). You may also assume that the input is correct, in particular that C is at least 1 and it doesn抰 exceed the number of cute fences with N planks.

Output

For each input data set output one line, describing the C-th fence with N planks in the catalogue. More precisely, if the fence is described by the permutation a1, . . . , aN, then the corresponding line of the output file should contain the numbers ai (in the correct order), separated by single spaces.

Sample Input

2
2 1
3 3

Sample Output

1 2
2 3 1

Source


题意:有1~n的n根木棒,波浪形全排列的第m个数列是什么
#include <iostream>
#include <stdio.h>
#include <string.h>
#include <stack>
#include <queue>
#include <map>
#include <set>
#include <vector>
#include <math.h>
#include <bitset>
#include <algorithm>
#include <climits>
using namespace std;

#define LS 2*i
#define RS 2*i+1
#define UP(i,x,y) for(i=x;i<=y;i++)
#define DOWN(i,x,y) for(i=x;i>=y;i--)
#define MEM(a,x) memset(a,x,sizeof(a))
#define W(a) while(a)
#define LL long long
#define N 25
#define MOD 19999997
#define INF 0x3f3f3f3f
#define EXP 1e-8

const double Pi = acos(-1.0);

int t,n;
LL m;
LL dp[N][N][2];//0-UP,1-DOWN
//dp[i][k][1] 是以第k短的木棒打头的DOWN方案数,C[i][k][0]是以第k短的木棒打头的UP方案数,第k短指i根中第k短
int a[N],ans[N],vis[N];

void solve()
{
    int i,j,k,cnt;
    LL now=0,pre;//已经枚举的方案数
    MEM(vis,0);
    MEM(ans,0);
    UP(i,1,n)
    {
        cnt = 0;
        UP(j,1,n)//枚举所有木棒
        {
            pre = now;
            if(!vis[j])
            {
                cnt++;
                if(i==1)
                    now+=dp[n][cnt][0]+dp[n][cnt][1];
                else if(j>ans[i-1] && (i==2 || ans[i-2]>ans[i-1]))
                    now+=dp[n-i+1][cnt][1];
                else if(j<ans[i-1] && (i==2 || ans[i-2]<ans[i-1]))
                    now+=dp[n-i+1][cnt][0];
                if(now>=m) break;//后面所有数的全排列的数量加上来超过m,我们能确定这位放j
            }
        }
        vis[j] = 1;
        ans[i]=j;
        now = pre;
    }
    printf("%d",ans[1]);
    UP(i,2,n)
    printf(" %d",ans[i]);
    printf("\n");
}

int main()
{
    int i,j,k;
    MEM(dp,0);
    dp[1][1][0]=dp[1][1][1] = 1;
    UP(i,2,20)
    {
        UP(j,1,i)//枚举第一根木棒的长度
        {
            //第二根的长度
            UP(k,j,i-1) dp[i][j][0]+=dp[i-1][k][1];
            UP(k,1,j-1) dp[i][j][1]+=dp[i-1][k][0];
        }
    }
    scanf("%d",&t);
    W(t--)
    {
        scanf("%d%I64d",&n,&m);
        solve();
    }

    return 0;
}


POJ1037:A decorative fence(DP)

标签:poj

原文地址:http://blog.csdn.net/libin56842/article/details/45700903

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!