码迷,mamicode.com
首页 > 其他好文 > 详细

杨辉三角

时间:2015-05-14 16:43:08      阅读:118      评论:0      收藏:0      [点我收藏+]

标签:

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 42996    Accepted Submission(s): 18055


Problem Description
还记得中学时候学过的杨辉三角吗?具体的定义这里不再描述,你可以参考以下的图形:
1
1 1
1 2 1
1 3 3 1
1 4 6 4 1
1 5 10 10 5 1
 

Input
输入数据包含多个测试实例,每个测试实例的输入只包含一个正整数n(1<=n<=30),表示将要输出的杨辉三角的层数。
 

Output
对应于每一个输入,请输出相应层数的杨辉三角,每一层的整数之间用一个空格隔开,每一个杨辉三角后面加一个空行。
 

Sample Input
2 3
 

Sample Output
1 1 1 1 1 1 1 2 1


#include<stdio.h>

main()
{
int n,i,j,x[39][39]={1};
while(scanf("%d",&n)!=EOF)
{
for(i=1;i<=n;i++)
for(j=1;j<=i;j++)
{
x[i][j]=x[i-1][j]+x[i-1][j-1];
if(i!=j) 
printf("%d ",x[i][j]);
else
printf("%d\n",1);
}
printf("\n");
}
return 0;
}

杨辉三角

标签:

原文地址:http://blog.csdn.net/l15738519366/article/details/45720261

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!