码迷,mamicode.com
首页 > 其他好文 > 详细

(树形DP) poj 3659

时间:2015-05-14 18:00:34      阅读:142      评论:0      收藏:0      [点我收藏+]

标签:

Cell Phone Network
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 5916   Accepted: 2119

Description

Farmer John has decided to give each of his cows a cell phone in hopes to encourage their social interaction. This, however, requires him to set up cell phone towers on his N (1 ≤ N ≤ 10,000) pastures (conveniently numbered 1..N) so they can all communicate.

Exactly N-1 pairs of pastures are adjacent, and for any two pastures A and B (1 ≤ A ≤ N; 1 ≤ B ≤ NA ≠ B) there is a sequence of adjacent pastures such that is the first pasture in the sequence and B is the last. Farmer John can only place cell phone towers in the pastures, and each tower has enough range to provide service to the pasture it is on and all pastures adjacent to the pasture with the cell tower.

Help him determine the minimum number of towers he must install to provide cell phone service to each pasture.

Input

* Line 1: A single integer: N
* Lines 2..N: Each line specifies a pair of adjacent pastures with two space-separated integers: A and B

Output

* Line 1: A single integer indicating the minimum number of towers to install

Sample Input

5
1 3
5 2
4 3
3 5

Sample Output

2

Source

 

题意:求树的最小支配集

求树最小支配集。
               设dp[u][0]表示选择u这个点,且以u为根的子树完全被覆盖的最小个数。
               设dp[u][1]表示u这个点被其儿子覆盖,且以u为根的子树完全被覆盖的最小个数。
               设dp[u][2]表示u这个点被其父亲覆盖,且以u为根的子树完全被覆盖的最小个数。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<cmath>
#include<cstdlib>
#include<algorithm>
#include<queue>
#include<vector>
#include<set>
#define INF 100000000
using namespace std;
vector<int> e[10005];
int dp[10005][3];
int n;
void dfs(int u,int father)
{
    dp[u][0]=1;
    dp[u][1]=INF;
    dp[u][2]=0;
    for(int i=0;i<e[u].size();i++)
    {
        int v=e[u][i];
        if(v==father)
            continue;
        dfs(v,u);
        dp[u][0]+=min(dp[v][0],dp[v][2]);
        dp[u][2]+=min(dp[v][0],dp[v][1]);
    }
    for(int i=0;i<e[u].size();i++)
    {
        int v=e[u][i];
        if(v==father)
            continue;
        dp[u][1]=min(dp[u][1],dp[u][2]-min(dp[v][0],dp[v][1])+dp[v][0]);
    }
}
int main()
{
    scanf("%d",&n);
    for(int i=1;i<n;i++)
    {
        int x,y;
        scanf("%d%d",&x,&y);
        e[x].push_back(y);
        e[y].push_back(x);
    }
    dfs(1,-1);
    printf("%d\n",min(dp[1][0],dp[1][1]));
    return 0;
}

  

(树形DP) poj 3659

标签:

原文地址:http://www.cnblogs.com/water-full/p/4503584.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!