码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 1083 Courses(二分图匹配)

时间:2015-05-15 09:09:17      阅读:107      评论:0      收藏:0      [点我收藏+]

标签:hdu 1083 courses   二分图匹配   匈牙利算法   

Courses

Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4278    Accepted Submission(s): 2036


Problem Description
Consider a group of N students and P courses. Each student visits zero, one or more than one courses. Your task is to determine whether it is possible to form a committee of exactly P students that satisfies simultaneously the conditions:

. every student in the committee represents a different course (a student can represent a course if he/she visits that course)

. each course has a representative in the committee

Your program should read sets of data from a text file. The first line of the input file contains the number of the data sets. Each data set is presented in the following format:

P N
Count1 Student1 1 Student1 2 ... Student1 Count1
Count2 Student2 1 Student2 2 ... Student2 Count2
...... 
CountP StudentP 1 StudentP 2 ... StudentP CountP

The first line in each data set contains two positive integers separated by one blank: P (1 <= P <= 100) - the number of courses and N (1 <= N <= 300) - the number of students. The next P lines describe in sequence of the courses . from course 1 to course P, each line describing a course. The description of course i is a line that starts with an integer Count i (0 <= Count i <= N) representing the number of students visiting course i. Next, after a blank, you‘ll find the Count i students, visiting the course, each two consecutive separated by one blank. Students are numbered with the positive integers from 1 to N.

There are no blank lines between consecutive sets of data. Input data are correct.

The result of the program is on the standard output. For each input data set the program prints on a single line "YES" if it is possible to form a committee and "NO" otherwise. There should not be any leading blanks at the start of the line.

An example of program input and output:
 

Sample Input
2 3 3 3 1 2 3 2 1 2 1 1 3 3 2 1 3 2 1 3 1 1
 

Sample Output
YES NO
 

Source
 

题意:p门课,n个学生,选课代表,一个学生只能做一个课代表,每门课也有限制谁能当课代表,求问能不能满足所有课都有课代表,满足输出“YES”,否则“NO”。

题解:分别以科目,学生各为一个集合,建边,然后求匹配。

#include<cstring>
#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cmath>
#include<vector>
#define N 333

using namespace std;

int n,p;
vector<int>G[N];
int linker[N];
bool used[N];

bool dfs(int u) {
    int v;
    for(v=0; v<G[u].size(); v++) {
        int i=G[u][v];
        if(!used[i]) {
            used[i]=true;
            if(linker[i]==-1||dfs(linker[i])) {
                linker[i]=u;
                return true;
            }
        }
    }
    return false;
}

int hungary() {
    int res=0;
    int u;
    memset(linker,-1,sizeof(linker));
    for(u=1; u<=p; u++) {
        memset(used,0,sizeof(used));
        if(dfs(u))  res++;
    }
    return res;
}

int main() {
   // freopen("in.txt","r",stdin);
    int t;
    cin>>t;
    while(t--) {
        for(int i=0; i<N; i++)G[i].clear();
        scanf("%d%d",&p,&n);
        for(int i=1; i<=p; i++) {
            int num,x;
            scanf("%d",&num);
            while(num--) {
                scanf("%d",&x);
                G[i].push_back(x);
            }
        }
        int res=hungary();
        if(res<p)printf("NO\n");
        else     printf("YES\n");
    }
    return 0;
}


hdu 1083 Courses(二分图匹配)

标签:hdu 1083 courses   二分图匹配   匈牙利算法   

原文地址:http://blog.csdn.net/acm_baihuzi/article/details/45727991

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!