Coins
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 8770 Accepted Submission(s): 3531
Problem Description
Whuacmers use coins.They have coins of value A1,A2,A3...An Silverland dollar. One day Hibix opened purse and found there were some coins. He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the
price would not more than m.But he didn‘t know the exact price of the watch.
You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony‘s coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins.
Input
The input contains several test cases. The first line of each test case contains two integers n(1 ≤ n ≤ 100),m(m ≤ 100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1 ≤ Ai ≤ 100000,1 ≤ Ci ≤ 1000). The last test case is followed
by two zeros.
Output
For each test case output the answer on a single line.
Sample Input
3 10
1 2 4 2 1 1
2 5
1 4 2 1
0 0
Sample Output
Source
#include <bits/stdc++.h>
using namespace std;
#define prt(k) cerr<<#k" = "<<k<<endl
const int N = 102;
const int M = 100002;
int dp[2][M];
const int inf = 0x3f3f3f3f;
int n, m;
int a[N], c[N];
int main()
{
int re, ca=1;
while (cin >> n >> m , n)
{
for (int i=1; i<=n; i++) scanf("%d", a+i);
for (int i=1; i<=n; i++) scanf("%d", c+i);
memset(dp ,63, sizeof dp);
int u = 1;
for (int i=0;i<=c[1] && a[1]*i<=m; i++) dp[u][a[1]*i] = i;
for (int i=2; i<=n; i++)
{
u = 1 - u;
memset(dp[u], 63, sizeof dp[u]);
dp[ u ][0] = 0;
for (int j=1; j<=m; j++)
{
if (dp[ 1 - u ][j] <= c[i-1] )
dp[u][j] = 0;
else if (j >= a[i])
{
dp[u][j] = min(dp[u][j], dp[ u ][j-a[i]] + 1);
}
}
}
int ans = 0;
for (int i=1; i<=m; i++) if ( dp[u][i] <= c[n] ) ans ++;
cout<<ans<<endl;
}
}