标签:
Catch That Cow
Time Limit: 2000MS |
|
Memory Limit: 65536K |
Total Submissions: 54700 |
|
Accepted: 17101 |
Description
Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point
N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point
K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.
* Walking: FJ can move from any point X to the points X - 1 or
X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.
If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?
Input
Line 1: Two space-separated integers: N and
K
Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
Sample Input
5 17
Sample Output
4
Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.
Source
USACO 2007 Open Silver
再次应证了我刚开始接触搜索时看到的一句话:搜索很强大的!
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
#include<queue>
using namespace std;
int N,K,vis[1000010];
const int M =1000000;
struct node{
int x,step;
};
int check(int x)
{
if(x<0 || x>=M||vis[x])return 0; //这里好像要把判边界放在前面,否则会爆。。可能判边界的情况更多
return 1;
}
int bfs(int x)
{
queue<node>Q;
int i;
node p,a;
p.x=x;
p.step=0;
vis[x]=1;
Q.push(p);
while(!Q.empty())
{
p=Q.front();
Q.pop();
if(p.x==K)return p.step;
a=p;
a.x=p.x+1;
if(check(a.x))
{
a.step=p.step+1;
vis[a.x]=1;
Q.push(a);
}
a.x=p.x-1;
if(check(a.x)){
a.step=p.step+1;
vis[a.x]=1;
Q.push(a);
}
a.x = p.x*2;
if(check(a.x)){
a.step=p.step+1;
vis[a.x]=1;
Q.push(a);
}
}
return 0;
}
int main()
{
int ans;
while(scanf("%d%d",&N,&K)!=EOF)
{
memset(vis,0,sizeof(vis));
ans=bfs(N);
printf("%d\n",ans);
}
return 0;
}
poj 3278 Catch That Cow(bfs)
标签:
原文地址:http://blog.csdn.net/aaaaacmer/article/details/45767805