码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 1979 Red and Black

时间:2015-05-17 10:51:05      阅读:117      评论:0      收藏:0      [点我收藏+]

标签:

Red and Black
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 25014   Accepted: 13502

Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can‘t move on red tiles, he can move only on black tiles. 

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20. 

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows. 

‘.‘ - a black tile 
‘#‘ - a red tile 
‘@‘ - a man on a black tile(appears exactly once in a data set) 
The end of the input is indicated by a line consisting of two zeros. 

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13


#include <iostream>
#include <stdio.h>
#include <string>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <queue>
#define N 1009
using namespace std;
char s[N][N];

int n,m;
int sx,sy;
int dis[4][2]={ {0,1},{0,-1},{1,0},{-1,0} };
int sum;

void dfs(int x,int y)
{
    for(int i=0;i<4;i++)
    {
        int xx=x+dis[i][0];
        int yy=y+dis[i][1];
        if(xx>=0 && xx<n && yy>=0 && yy<m && s[xx][yy]=='.')
        {
           s[xx][yy]='#';
           sum++;
           dfs(xx,yy);
        }
    }
}

int main()
{
    while(scanf("%d %d",&m,&n)!=EOF)
    {
        if(n+m<=0) break;

        sum=1;//起点一定算一个答案,如果只有一个点的话,那么答案将输出0

        for(int i=0;i<n;i++)
        {
            scanf("%s",s[i]);
            for(int j=0;j<m;j++)
            {
                if(s[i][j]=='@')//起点已经算了一个,直接修改成#
                {
                    sx=i;
                    sy=j;
                    s[i][j]='#';
                    break;
                }
            }
        }

        dfs(sx,sy);
        printf("%d\n",sum);

    }
    return 0;
}





POJ 1979 Red and Black

标签:

原文地址:http://blog.csdn.net/wust_zjx/article/details/45786815

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!