标签:acm 杭电 算法 编程 c++
How Many Tables
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 17049 Accepted Submission(s): 8349
Problem Description
Today is Ignatius‘ birthday. He invites a lot of friends. Now it‘s dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want
to stay with strangers.
One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.
For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.
Input
The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked
from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.
Output
For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.
Sample Input
2
5 3
1 2
2 3
4 5
5 1
2 5
Sample Output
Author
Ignatius.L
Source
改用了非递归形式的路径压缩,即先循环找到根节点,然后把路径上所有结点设置为根节点值。 注意到每个集合的代表元素就是根结点,然后放入set求大小就行了。
#include<iostream>
#include<set>
using namespace std;
const int T=1003;
int F[T];
int Find(int x)
{
int t,r,k;
r=x;
while(F[r]!=r)
{
r=F[r];
}
k=x;
while(k!=r)
{
t=F[k];
F[k]=r;
k=t;
}
return r;
}
void union_set(int x,int y)
{
int tx=Find(x);
int ty=Find(y);
if(tx!=ty)
{
F[tx]=ty;
}
}
int main()
{
int t;
cin>>t;
while(t--)
{
set<int>dic;
int n,m;
cin>>n>>m;
for(int i=1;i<=n;i++)
F[i]=i;
for(int k=0;k<m;k++)
{
int a,b;
cin>>a>>b;
union_set(a,b);
}
for(int j=1;j<=n;j++)
{
//cout<<"Find(j)="<<Find(j)<<endl;
dic.insert(Find(j));
}
cout<<dic.size()<<endl;
}
return 0;
}
杭电 HDU ACM 1213 How Many Tables
标签:acm 杭电 算法 编程 c++
原文地址:http://blog.csdn.net/lsgqjh/article/details/45794957