码迷,mamicode.com
首页 > 其他好文 > 详细

poj 1088 滑雪(线性DP)

时间:2015-05-18 12:59:49      阅读:130      评论:0      收藏:0      [点我收藏+]

标签:

滑雪
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 81553   Accepted: 30437

Description

Michael喜欢滑雪百这并不奇怪, 因为滑雪的确很刺激。可是为了获得速度,滑的区域必须向下倾斜,而且当你滑到坡底,你不得不再次走上坡或者等待升降机来载你。Michael想知道载一个区域中最长底滑坡。区域由一个二维数组给出。数组的每个数字代表点的高度。下面是一个例子
 1  2  3  4 5

16 17 18 19 6

15 24 25 20 7

14 23 22 21 8

13 12 11 10 9

一个人可以从某个点滑向上下左右相邻四个点之一,当且仅当高度减小。在上面的例子中,一条可滑行的滑坡为24-17-16-1。当然25-24-23-...-3-2-1更长。事实上,这是最长的一条。

Input

输入的第一行表示区域的行数R和列数C(1 <= R,C <= 100)。下面是R行,每行有C个整数,代表高度h,0<=h<=10000。

Output

输出最长区域的长度。

Sample Input

5 5
1 2 3 4 5
16 17 18 19 6
15 24 25 20 7
14 23 22 21 8
13 12 11 10 9

Sample Output

25

 

题目链接:http://poj.org/problem?id=1088

 

解题思路:把矩阵里每点的高度按递减排序,然后线性DP找最长坡值,判断条件加上是否相邻即可。

 

代码如下:

 

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn=10005;

struct DP        
{
	int v;       //记录矩阵中每个位置的高度
	int step;    //记录以该位置为末位置的最长坡度
	int r,c;     //记录该点的横纵坐标
}dp[maxn]; 

int cmp(DP a,DP b)   
{
	return a.v>b.v;
}
//排序时以DP结构体的高度值递减排序

int main()
{
	int n,m,i,j;
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		int cnt=0,ans=1;
		for(i=0;i<n;i++)
			for(j=0;j<m;j++)
			{
				scanf("%d",&dp[cnt].v);
				dp[cnt].step=1;
				dp[cnt].r=i;
				dp[cnt].c=j;
				cnt++;
			}
		//按矩阵格式输入每个点的高度值,每个点的step初始化为1

		sort(dp,dp+cnt,cmp);

		for(i=0;i<cnt;i++)
		{
			int r1=dp[i].r;
			int c1=dp[i].c;
			for(j=0;j<i;j++)
			{
				int r2=dp[j].r;
				int c2=dp[j].c;
				if(r1==r2&&c1+1==c2||r1==r2&&c2+1==c1||c1==c2&&r1+1==r2||c1==c2&&r2+1==r1)
				{
					if(dp[i].v<dp[j].v&&dp[i].step<dp[j].step+1)
						dp[i].step=dp[j].step+1;
					ans=ans>dp[i].step?ans:dp[i].step;
				}
				//如果为两位置相邻且前一个位置高于后一个位置,则比较并更新坡长值。
			}
		}
		printf("%d\n",ans);
	}
	return 0;
}


 

poj 1088 滑雪(线性DP)

标签:

原文地址:http://blog.csdn.net/criminalcode/article/details/45817001

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!