码迷,mamicode.com
首页 > 其他好文 > 详细

UVA253-Cube painting

时间:2015-05-19 12:53:48      阅读:133      评论:0      收藏:0      [点我收藏+]

标签:

Cube painting 

We have a machine for painting cubes. It is supplied with three different colors: blue, red and green. Each face of the cube gets one of these colors. The cube‘s faces are numbered as in Figure 1.

 

技术分享

 

 

Figure 1.

Since a cube has 6 faces, our machine can paint a face-numbered cube in 技术分享 different ways. When ignoring the face-numbers, the number of different paintings is much less, because a cube can be rotated. See example below. We denote a painted cube by a string of 6 characters, where each character is a br, org. The 技术分享 character ( 技术分享 ) from the left gives the color of face i. For example, Figure 2 is a picture of rbgggr and Figure 3 corresponds to rggbgr. Notice that both cubes are painted in the same way: by rotating it around the vertical axis by 90 技术分享 , the one changes into the other.

技术分享 技术分享

Input

The input of your program is a textfile that ends with the standard end-of-file marker. Each line is a string of 12 characters. The first 6 characters of this string are the representation of a painted cube, the remaining 6 characters give you the representation of another cube. Your program determines whether these two cubes are painted in the same way, that is, whether by any combination of rotations one can be turned into the other. (Reflections are not allowed.)

 

Output

The output is a file of boolean. For each line of input, output contains TRUE if the second half can be obtained from the first half by rotation as describes above, FALSE otherwise.

 

Sample Input

 

rbgggrrggbgr
rrrbbbrrbbbr
rbgrbgrrrrrg

 

Sample Output

 

TRUE
FALSE
FALSE




这个方法是参考大神的,实在是不能太6.
#include <cstdio>
#include <cstring>

char str[15];
int vis[3];        /*每两个对面形成一组颜色对, 每个正方体有三个颜色对,
                匹配下三个颜色对是否相同。(用vis标记检查顺序)*/

int main()
{
    while(scanf("%s", str) != EOF)
    {
        int cnt = 0;
        memset(vis, 0, sizeof(vis));
        for(int i = 0; i < 3; i++)
        {
            for(int j = 0; j < 3; j++)
            {
                if((str[i] == str[6+j] && str[5-i] == str[11-j]) || (str[i] == str[11-j] && str[5-i] == str[6+j]) && !vis[j])
                {
                    vis[j] = 1;
                    cnt++;
                    break;
                }
            }
        }
        if(cnt == 3) printf("TRUE\n");
        else printf("FALSE\n");
    }
}

 

UVA253-Cube painting

标签:

原文地址:http://www.cnblogs.com/hsq666/p/4514078.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!