码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 1003

时间:2015-05-21 12:28:57      阅读:121      评论:0      收藏:0      [点我收藏+]

标签:

Hangover

Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 108445   Accepted: 52837

Description

How far can you make a stack of cards overhang a table? If you have one card, you can create a maximum overhang of half a card length. (We‘re assuming that the cards must be perpendicular to the table.) With two cards you can make the top card overhang the bottom one by half a card length, and the bottom one overhang the table by a third of a card length, for a total maximum overhang of 1/2 + 1/3 = 5/6 card lengths. In general you can make n cards overhang by 1/2 + 1/3 + 1/4 + ... + 1/(n + 1) card lengths, where the top card overhangs the second by 1/2, the second overhangs tha third by 1/3, the third overhangs the fourth by 1/4, etc., and the bottom card overhangs the table by 1/(n + 1). This is illustrated in the figure below.


技术分享

Input

The input consists of one or more test cases, followed by a line containing the number 0.00 that signals the end of the input. Each test case is a single line containing a positive floating-point number c whose value is at least 0.01 and at most 5.20; c will contain exactly three digits.

Output

For each test case, output the minimum number of cards necessary to achieve an overhang of at least c card lengths. Use the exact output format shown in the examples.

Sample Input

1.00
3.71
0.04
5.19
0.00

Sample Output

3 card(s)
61 card(s)
1 card(s)
273 card(s)

CODE:
#include <iostream>
#include <cstdio>
#include <cstring>
#define REP(i, s, n) for(int i = s; i <= n; i ++)
#define REP_(i, s, n) for(int i = n; i >= s; i --)
#define MAX_N 300 + 10

using namespace std;

int main(){
    double n;
    while(cin >> n){
        if(n == 0.00) break;
        int tmp = 1; double sum = 0;
        while(sum < n){
            sum += (double) 1 / ++ tmp;
        }
        tmp --;
        printf("%d card(s)\n", tmp);
    }
    return 0;
}

 

 

POJ 1003

标签:

原文地址:http://www.cnblogs.com/ALXPCUN/p/4519286.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!