码迷,mamicode.com
首页 > 其他好文 > 详细

R - Milking Time POJ 3616 ( DP )

时间:2015-05-21 12:47:44      阅读:101      评论:0      收藏:0      [点我收藏+]

标签:


R - Milking Time
Time Limit:1000MS Memory Limit:65536KB 64bit IO Format:%I64d & %I64u
Submit Status Practice POJ 3616

Description

Bessie is such a hard-working cow. In fact, she is so focused on maximizing her productivity that she decides to schedule her next N (1 ≤ N ≤ 1,000,000) hours (conveniently labeled 0..N-1) so that she produces as much milk as possible.

Farmer John has a list of M (1 ≤ M ≤ 1,000) possibly overlapping intervals in which he is available for milking. Each interval i has a starting hour (0 ≤ starting_houri ≤ N), an ending hour (starting_houri < ending_houri ≤ N), and a corresponding efficiency (1 ≤ efficiencyi ≤ 1,000,000) which indicates how many gallons of milk that he can get out of Bessie in that interval. Farmer John starts and stops milking at the beginning of the starting hour and ending hour, respectively. When being milked, Bessie must be milked through an entire interval.

Even Bessie has her limitations, though. After being milked during any interval, she must rest R (1 ≤ R ≤ N) hours before she can start milking again. Given Farmer Johns list of intervals, determine the maximum amount of milk that Bessie can produce in the N hours.

Input

* Line 1: Three space-separated integers: N, M, and R
* Lines 2..M+1: Line i+1 describes FJ‘s ith milking interval withthree space-separated integers: starting_houri , ending_houri , and efficiencyi

Output

* Line 1: The maximum number of gallons of milk that Bessie can product in the N hours

Sample Input

12 4 2
1 2 8
10 12 19
3 6 24
7 10 31

Sample Output

43

先把读入的区间从小到大排序,然后dp



#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn=10005;
struct node
{
    int l,r,data;
    bool operator<(const node& tmp) const{
        if(l!=tmp.l)
            return l<tmp.l;
        else
            return r<tmp.r;
    }
}p[maxn];

int dp[maxn];//表示选择到第M个区间 能获得的最大值

int main()
{
    int n,m,r;
    while(~scanf("%d%d%d",&n,&m,&r)){
        for(int i=0;i<m;i++){
            scanf("%d%d%d",&p[i].l,&p[i].r,&p[i].data);
            dp[i]=0;
        }
        sort(p,p+m);
        int j;
        for(int i=0;i<m;i++){
            int maxx=0;
            for(j=0;j<i;j++)if(p[i].l-p[j].r>=r){
                maxx=max(maxx,dp[j]);//找到这个区间前面的最大值
            }
            dp[i]=maxx+p[i].data;
        }
       printf("%d\n",*max_element(dp,dp+m+1));
    }
    return 0;
}















R - Milking Time POJ 3616 ( DP )

标签:

原文地址:http://blog.csdn.net/u013167299/article/details/45889349

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!