码迷,mamicode.com
首页 > 其他好文 > 详细

HDU1003——DP——Max Sum

时间:2015-05-21 17:06:47      阅读:139      评论:0      收藏:0      [点我收藏+]

标签:

Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 

 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 

 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 

 

Sample Input
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
 

 

Sample Output
Case 1: 14 1 4 Case 2: 7 1 6
 

 

Author
Ignatius.L
 

 

Recommend
We have carefully selected several similar problems for you:  1176 1087 1069 2084 1058 
很简单的dp,dp[i]表示以i为开头的值
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn = 100010;
const int inf = 0x3f3f3f3f;
int a[maxn],dp[maxn];
int T,n;

int main()
{
    scanf("%d",&T);
    for(int cas = 1; cas <= T; cas++){
        scanf("%d",&n);
        for(int i = 1; i <= n ;i++){
            scanf("%d",&a[i]);
            dp[i] = a[i];
        }
        for(int i = n-1; i >= 1; i--){
            dp[i] = max(dp[i], dp[i+1] + a[i]);
        }
       // for(int i = 1; i <= n; i++)
       //     printf("%d ",dp[i]);
        int index;
        int max1 = -inf;
        for(int i = 1; i <= n ;i++){
            if(max1 < dp[i]){
                 max1 = dp[i];
                index = i;
            }
        }
        int res = 0;
        int index1;
        for(int i = index; i <= n; i++){
            res += a[i];
            if(res == max1){
                index1 = i;
                break;
            }
        }
    printf("Case %d:\n",cas);
    printf("%d %d %d\n",max1,index,index1);
   if(cas < T) printf("\n");
    }
    return 0;
}
        

  

HDU1003——DP——Max Sum

标签:

原文地址:http://www.cnblogs.com/zero-begin/p/4520026.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!