码迷,mamicode.com
首页 > 其他好文 > 详细

HDU1520——树形DP——Anniversary party

时间:2015-05-21 23:57:35      阅读:308      评论:0      收藏:0      [点我收藏+]

标签:

Problem Description
There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests‘ conviviality ratings.
 

 

Input
Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go T lines that describe a supervisor relation tree. Each line of the tree specification has the form: 
L K 
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line 
0 0
 

 

Output
Output should contain the maximal sum of guests‘ ratings.
 

 

Sample Input
7 1 1 1 1 1 1 1 1 3 2 3 6 4 7 4 4 5 3 5 0 0
 

 

Sample Output
5
 

 

Source

 大意:给你一些人的快乐指数,而且满足下级不能与直接上级一起去参加party,求最大的快乐指数

定义 dp[i][j] 表示第i个人去还是没去

状态转移方程 dp[x][1] += dp[G[x][i]][1];

                  dp[x][0] += max(dp[G[x][i]][1],dp[G[x][i]][0]);

用并查集的思想找到根,对着根进行DFS

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<vector>
using namespace std;
int dp[6100][2];
int t[6100];
int f[6100];
vector<int> G[6100];
void dfs(int x)
{
    dp[x][1] = t[x];
    for(int i = 0; i < G[x].size(); i++){
        dfs(G[x][i]);
    }
    for(int i = 0 ; i < G[x].size();i++){
        dp[x][1] += dp[G[x][i]][0];
        dp[x][0] += max(dp[G[x][i]][1],dp[G[x][i]][0]);
    }
}

int main()
{
    int n,a,b;
    while(~scanf("%d",&n)){
        for(int i = 1; i <= n; i++)
            G[i].clear();
        for(int i = 1; i <= n ; i++)
            scanf("%d",&t[i]);
        memset(f,-1,sizeof(f));
        memset(dp,0,sizeof(dp));
        while(~scanf("%d%d",&a,&b)){
                if(a == 0 && b == 0) break;
            G[b].push_back(a);
            f[a] = b;
        }
       // for(int i = 1;  i<= n ;i++)
       //     printf("%d ",f[i]);
        int x = 1;
        while(f[x]!= -1) {
            x = f[x];
        }
        dfs(x);
    printf("%d\n",max(dp[x][0],dp[x][1]));
    }
    return 0;
}

  

HDU1520——树形DP——Anniversary party

标签:

原文地址:http://www.cnblogs.com/zero-begin/p/4520928.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!