码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 2350

时间:2015-05-22 08:13:34      阅读:95      评论:0      收藏:0      [点我收藏+]

标签:

Above Average

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 15028   Accepted: 7875

Description

It is said that 90% of frosh expect to be above average in their class. You are to provide a reality check.

Input

The first line of standard input contains an integer C, the number of test cases. C data sets follow. Each data set begins with an integer, N, the number of people in the class (1 <= N <= 1000). N integers follow, separated by spaces or newlines, each giving the final grade (an integer between 0 and 100) of a student in the class.

Output

For each case you are to output a line giving the percentage of students whose grade is above average, rounded to 3 decimal places.

Sample Input

5
5 50 50 70 80 100
7 100 95 90 80 70 60 50
3 70 90 80
3 70 90 81
9 100 99 98 97 96 95 94 93 91

Sample Output

40.000%
57.143%
33.333%
66.667%
55.556%

CODE:
#include <iostream>
#include <cstdio>
#include <cstring>
#define REP(i, s, n) for(int i = s; i <= n; i ++)
#define REP_(i, s, n) for(int i = n; i >= s; i --)
#define MAX_N 1000 + 10

using namespace std;

int main(){
    int T, n, a[MAX_N];
    scanf("%d", &T);
    while(T --){
        double sum = 0;
        scanf("%d", &n);
        REP(i, 1, n) scanf("%d", &a[i]), sum += (double)a[i];
        sum /= n; int ans = 0;
        REP(i, 1, n) if((double)a[i] > sum) ans ++;
        printf("%.3f%c\n", (double)ans / n * 100, %);
    }
    //system("pause");
    return 0;
}

 


POJ 2350

标签:

原文地址:http://www.cnblogs.com/ALXPCUN/p/4521364.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!