码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 题目1106 Transmitters(数学几何)

时间:2015-05-22 22:40:29      阅读:156      评论:0      收藏:0      [点我收藏+]

标签:

Transmitters
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 4756   Accepted: 2538

Description

In a wireless network with multiple transmitters sending on the same frequencies, it is often a requirement that signals don‘t overlap, or at least that they don‘t conflict. One way of accomplishing this is to restrict a transmitter‘s coverage area. This problem uses a shielded transmitter that only broadcasts in a semicircle.

A transmitter T is located somewhere on a 1,000 square meter grid. It broadcasts in a semicircular area of radius r. The transmitter may be rotated any amount, but not moved. Given N points anywhere on the grid, compute the maximum number of points that can be simultaneously reached by the transmitter‘s signal. Figure 1 shows the same data points with two different transmitter rotations.
技术分享

All input coordinates are integers (0-1000). The radius is a positive real number greater than 0. Points on the boundary of a semicircle are considered within that semicircle. There are 1-150 unique points to examine per transmitter. No points are at the same location as the transmitter.

Input

Input consists of information for one or more independent transmitter problems. Each problem begins with one line containing the (x,y) coordinates of the transmitter followed by the broadcast radius, r. The next line contains the number of points N on the grid, followed by N sets of (x,y) coordinates, one set per line. The end of the input is signalled by a line with a negative radius; the (x,y) values will be present but indeterminate. Figures 1 and 2 represent the data in the first two example data sets below, though they are on different scales. Figures 1a and 2 show transmitter rotations that result in maximal coverage.

Output

For each transmitter, the output contains a single line with the maximum number of points that can be contained in some semicircle.

Sample Input

25 25 3.5
7
25 28
23 27
27 27
24 23
26 23
24 29
26 29
350 200 2.0
5
350 202
350 199
350 198
348 200
352 200
995 995 10.0
4
1000 1000
999 998
990 992
1000 999
100 100 -2.5

Sample Output

3
4
4

Source

Mid-Central USA 2001

题目大意:给你一个半圆的圆心坐标,和半径,再给你一堆点的坐标,然后问半圆旋转可以覆盖最多几个点

ac代码

#include<stdio.h>
#include<string.h>
#include<math.h>
struct s
{
	double x,y;
}a,b[100100],c[100100];
double r;
double dis(struct s a,struct s b)
{
	return sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));
}
double cross(struct s a,struct s b,struct s c)
{
	return (b.x-a.x)*(c.y-a.y)-(c.x-a.x)*(b.y-a.y);
}
int main()
{
	while(scanf("%lf%lf%lf",&a.x,&a.y,&r)!=EOF)
	{
		int n,i,j,k=0;
		if(r<0)
			break;
		scanf("%d",&n);
		for(i=0;i<n;i++)
		{
			scanf("%lf%lf",&b[i].x,&b[i].y);
			if(dis(a,b[i])<=r)
			{
				c[k].x=b[i].x;
				c[k++].y=b[i].y;
			}
		}
		int ans=0,max=0;
		for(i=0;i<k;i++)
		{
			ans=1;
			for(j=0;j<k;j++)
			{
				if(cross(a,c[i],c[j])>=0&&i!=j)
				{
					ans++;
				}
			}
			if(ans>max)
			{
				max=ans;
			}
		}
		printf("%d\n",max);
	}
}


POJ 题目1106 Transmitters(数学几何)

标签:

原文地址:http://blog.csdn.net/yu_ch_sh/article/details/45920037

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!