码迷,mamicode.com
首页 > 其他好文 > 详细

UVA 662 Fast Food(DP)

时间:2015-05-23 00:05:57      阅读:135      评论:0      收藏:0      [点我收藏+]

标签:

The fastfood chain McBurger owns several restaurants along a highway. Recently, they have decided to build several depots along the highway, each one located at a restaurent and supplying several of the restaurants with the needed ingredients. Naturally, these depots should be placed so that the average distance between a restaurant and its assigned depot is minimized. You are to write a program that computes the optimal positions and assignments of the depots.


To make this more precise, the management of McBurger has issued the following specification: You will be given the positions of n restaurants along the highway as n integers 技术分享 (these are the distances measured from the company‘s headquarter, which happens to be at the same highway). Furthermore, a number 技术分享 will be given, the number of depots to be built.

The k depots will be built at the locations of k different restaurants. Each restaurant will be assigned to the closest depot, from which it will then receive its supplies. To minimize shipping costs, the total distance sum, defined as


技术分享

must be as small as possible.

Write a program that computes the positions of the k depots, such that the total distance sum is minimized.

Input 

The input file contains several descriptions of fastfood chains. Each description starts with a line containing the two integers n and kn and k will satisfy 技术分享技术分享技术分享. Following this will n lines containing one integer each, giving the positions di of the restaurants, ordered increasingly.

The input file will end with a case starting with n = k = 0. This case should not be processed.

Output 

For each chain, first output the number of the chain. Then output an optimal placement of the depots as follows: for each depot output a line containing its position and the range of restaurants it serves. If there is more than one optimal solution, output any of them. After the depot descriptions output a line containing the total distance sum, as defined in the problem text.


Output a blank line after each test case.

Sample Input 

6 3
5
6
12
19
20
27
0 0

Sample Output 

Chain 1
Depot 1 at restaurant 2 serves restaurants 1 to 3
Depot 2 at restaurant 4 serves restaurants 4 to 5
Depot 3 at restaurant 6 serves restaurant 6
Total distance sum = 8



考虑dp状态为dp[i][j]:前i个酒店建k个仓库的最小代价。
dp[i][j]=min(dp[k][j-1]+dis[k+1][i])(j-1<=k<i);
关于路径输出设path[i][j]为达到dp[i][j]状态的前一状态的末仓库。
易知道path[i][1]=0;
其他的就是递归输出了。
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<vector>
#include<string>
#include<iostream>
#include<queue>
#include<cmath>
#include<map>
#include<stack>
#include<bitset>
using namespace std;
#define REPF( i , a , b ) for ( int i = a ; i <= b ; ++ i )
#define REP( i , n ) for ( int i = 0 ; i < n ; ++ i )
#define CLEAR( a , x ) memset ( a , x , sizeof a )
typedef long long LL;
typedef pair<int,int>pil;
const int INF = 0x3f3f3f3f;
const int maxn=220;
int dis[maxn][maxn];
int dp[maxn][50];
int path[220][50];
int d[220];
int n,k,cnt;
int cal(int l,int r)
{
    int sum=0;
    int mid=(l+r)>>1;
    for(int i=l;i<=r;i++)
        sum+=abs(d[mid]-d[i]);
    return sum;
}
void print(int i,int x)
{
    if(x==0)
        return ;
    print(path[i][x],x-1);
    printf("Depot %d at restaurant %d serves restaurants %d to %d\n",x,(path[i][x]+1+i)/2,path[i][x]+1,i);
}
int main()
{
    int cas=1;
    while(~scanf("%d%d",&n,&k)&&(n+k))
    {
        CLEAR(dp,INF);
        CLEAR(path,0);cnt=1;
        REPF(i,1,n)  scanf("%d",&d[i]);
        for(int i=1;i<=n;i++)
            for(int j=1;j<=n;j++)
               dis[i][j]=cal(i,j);
        for(int i=1;i<=n;i++)
        {
            dp[i][1]=dis[1][i];
            path[i][1]=0;
        }
        for(int i=1;i<=n;i++)
        {
            for(int j=2;j<=k;j++)
            {
                for(int p=j-1;p<i;p++)
                    if(dp[p][j-1]+dis[p+1][i]<dp[i][j])
                    {
                        dp[i][j]=dp[p][j-1]+dis[p+1][i];
                        path[i][j]=p;//上个区间
                    }
            }
        }
        printf("Chain %d\n",cas++);
        print(n,k);
        printf("Total distance sum = %d\n\n",dp[n][k]);
    }
    return 0;
}


/*

*/


UVA 662 Fast Food(DP)

标签:

原文地址:http://blog.csdn.net/u013582254/article/details/45922345

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!