码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 1661 Assigments 贪心法题解

时间:2014-06-15 11:26:42      阅读:195      评论:0      收藏:0      [点我收藏+]

标签:des   style   class   blog   code   ext   

Problem Description
In a factory, there are N workers to finish two types of tasks (A and B). Each type has N tasks. Each task of type A needs xi time to finish, and each task of type B needs yj time to finish, now, you, as the boss of the factory, need to make an assignment, which makes sure that every worker could get two tasks, one in type A and one in type B, and, what‘s more, every worker should have task to work with and every task has to be assigned. However, you need to pay extra money to workers who work over the standard working hours, according to the company‘s rule. The calculation method is described as follow: if someone’ working hour t is more than the standard working hour T, you should pay t-T to him. As a thrifty boss, you want know the minimum total of overtime pay.
 

Input
There are multiple test cases, in each test case there are 3 lines. First line there are two positive Integers, N (N<=1000) and T (T<=1000), indicating N workers, N task-A and N task-B, standard working hour T. Each of the next two lines has N positive Integers; the first line indicates the needed time for task A1, A2…An (Ai<=1000), and the second line is for B1, B2…Bn (Bi<=1000).
 

Output
For each test case output the minimum Overtime wages by an integer in one line.
 

Sample Input
2 5 4 2 3 5
 

Sample Output
4

贪心思想:

1 先计算完成任务A的每个员工剩下多少时间

2 剩下时间越多的,就分配B任务时间越多

排序匹配,就很好计算了。

#include <cstdio>
#include <algorithm>
using namespace std;
int A[1001];
int B[1001];
int main()
{
	int N, T;
	while (~scanf("%d %d", &N, &T))
	{
		for (int i = 0; i < N; i++)
		{
			scanf("%d", &A[i]);
			A[i] = T - A[i];
		}
		for (int i = 0; i < N; i++)
		{
			scanf("%d", &B[i]);
		}
		sort(A, A+N);
		sort(B, B+N);
		int ans = 0;
		for (int i = N-1; i >= 0; i--)
		{
			A[i] = B[i] - A[i];
			if (A[i] > 0) ans += A[i];
		}
		printf("%d\n", ans);
	}
	return 0;
}



HDU 1661 Assigments 贪心法题解,布布扣,bubuko.com

HDU 1661 Assigments 贪心法题解

标签:des   style   class   blog   code   ext   

原文地址:http://blog.csdn.net/kenden23/article/details/30973365

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!