码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 4597 Play Game(记忆化)

时间:2015-05-24 08:54:53      阅读:134      评论:0      收藏:0      [点我收藏+]

标签:dfs+记忆化

Play Game

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65535/65535 K (Java/Others)
Total Submission(s): 894    Accepted Submission(s): 525


Problem Description
Alice and Bob are playing a game. There are two piles of cards. There are N cards in each pile, and each card has a score. They take turns to pick up the top or bottom card from either pile, and the score of the card will be added to his total score. Alice and Bob are both clever enough, and will pick up cards to get as many scores as possible. Do you know how many scores can Alice get if he picks up first?
 

Input
The first line contains an integer T (T≤100), indicating the number of cases.
Each case contains 3 lines. The first line is the N (N≤20). The second line contains N integer ai (1≤ai≤10000). The third line contains N integer bi (1≤bi≤10000).
 

Output
For each case, output an integer, indicating the most score Alice can get.
 

Sample Input
2 1 23 53 3 10 100 20 2 4 3
 

Sample Output
53 105
 

Source
 

Recommend
liuyiding   |   We have carefully selected several similar problems for you:  5235 5234 5233 5232 5231 
 



#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
#include<stack>
#include<vector>
#include<set>
#include<map>


#define L(x) (x<<1)
#define R(x) (x<<1|1)
#define MID(x,y) ((x+y)>>1)

#define eps 1e-8
typedef __int64 ll;

#define fre(i,a,b)  for(i = a; i <b; i++)
#define free(i,b,a) for(i = b; i >= a;i--)
#define mem(t, v)   memset ((t) , v, sizeof(t))
#define ssf(n)      scanf("%s", n)
#define sf(n)       scanf("%d", &n)
#define sff(a,b)    scanf("%d %d", &a, &b)
#define sfff(a,b,c) scanf("%d %d %d", &a, &b, &c)
#define pf          printf
#define bug         pf("Hi\n")

using namespace std;

#define INF 0x3f3f3f3f
#define N 22

int a[N],b[N];
int dp[N][N][N][N];
int n;
int suma[N],sumb[N];

int dfs(int le,int ri,int lle,int rri)
{
	if(dp[le][ri][lle][rri]!=-1) return dp[le][ri][lle][rri];
	int i,j;
	int temp=0;

    if(le>ri&&lle>rri)
			return dp[le][ri][lle][rri]=0;
	temp+=suma[ri]-suma[le-1];
	temp+=sumb[rri]-sumb[lle-1];
	int ans=0;

	if(le<=ri)
	{
		ans=max(ans,temp-dfs(le+1,ri,lle,rri));
		ans=max(ans,temp-dfs(le,ri-1,lle,rri));
	}
   if(lle<=rri)
	{
		ans=max(ans,temp-dfs(le,ri,lle+1,rri));
		ans=max(ans,temp-dfs(le,ri,lle,rri-1));
	}
   return dp[le][ri][lle][rri]=ans;
}

int main()
{
	int i,j;
	int t;
	sf(t);
	while(t--)
	{
		scanf("%d",&n);
		for(i=1;i<=n;i++)
		{
			scanf("%d",&a[i]);
			suma[i]=suma[i-1]+a[i];
		}
        for(i=1;i<=n;i++)
		{
			sf(b[i]);
			sumb[i]=sumb[i-1]+b[i];
		}
	   mem(dp,-1);
       pf("%d\n",dfs(1,n,1,n));
	}
  return 0;
}





HDU 4597 Play Game(记忆化)

标签:dfs+记忆化

原文地址:http://blog.csdn.net/u014737310/article/details/45938615

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!