码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 2386 Lake Counting

时间:2015-05-24 21:36:11      阅读:98      评论:0      收藏:0      [点我收藏+]

标签:

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 22932   Accepted: 11567

Description

Due to recent rains, water has pooled in various places in Farmer John‘s field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water (‘W‘) or dry land (‘.‘). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors.

Given a diagram of Farmer John‘s field, determine how many ponds he has.

Input

* Line 1: Two space-separated integers: N and M

* Lines 2..N+1: M characters per line representing one row of Farmer John‘s field. Each character is either ‘W‘ or ‘.‘. The characters do not have spaces between them.

Output

* Line 1: The number of ponds in Farmer John‘s field.

Sample Input

10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.

Sample Output

3

Hint

OUTPUT DETAILS:

There are three ponds: one in the upper left, one in the lower left,and one along the right side.
 
题解:DFS
CODE:
#include <iostream>
#include <cstdio>
#include <cstring>
#define REP(i, s, n) for(int i = s; i <= n; i ++)
#define REP_(i, s, n) for(int i = n; i >= s; i --)
#define MAX_N 100 + 10

using namespace std;

bool map[MAX_N][MAX_N];
int n, m, ans = 0;
char ch;
int dx[9] = {0, -1, -1, -1, 0, 0, 1, 1, 1},
    dy[9] = {0, -1, 0, 1, -1, 1, -1, 0, 1};

void dfs(int x, int y){
    REP(i, 1, 8){
        if(x + dx[i] > 0 && x + dx[i] <= n && y + dy[i] > 0 && y + dy[i] <= m && map[x + dx[i]][y + dy[i]])
            map[x + dx[i]][y + dy[i]] = 0, dfs(x + dx[i], y + dy[i]);
    }
}        
    
int main(){
    scanf("%d%d", &n, &m);getchar();
    REP(i, 1, n){
        REP(j, 1, m) scanf("%c", &ch),
        map[i][j] = (ch == W ? 1 : 0);
        getchar();
    }
    
    REP(i, 1, n) REP(j, 1, m){
        if(map[i][j]) dfs(i, j), ans ++;
    }
    printf("%d\n", ans);
    return 0;
} 

 

POJ 2386 Lake Counting

标签:

原文地址:http://www.cnblogs.com/ALXPCUN/p/4526407.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!