码迷,mamicode.com
首页 > 其他好文 > 详细

An Easy Task

时间:2015-05-25 14:38:26      阅读:116      评论:0      收藏:0      [点我收藏+]

标签:

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 16797    Accepted Submission(s): 10727


Problem Description
Ignatius was born in a leap year, so he want to know when he could hold his birthday party. Can you tell him?

Given a positive integers Y which indicate the start year, and a positive integer N, your task is to tell the Nth leap year from year Y.

Note: if year Y is a leap year, then the 1st leap year is year Y.
 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains two positive integers Y and N(1<=N<=10000).
 

Output
For each test case, you should output the Nth leap year from year Y.
 

Sample Input
3 2005 25 1855 12 2004 10000
 

Sample Output
2108 1904 43236
Hint
We call year Y a leap year only if (Y%4==0 && Y%100!=0) or Y%400==0.
 



方法一:

#include<stdio.h>

int main()
{
int n,i;
scanf("%d",&n);
while(n--)
{
int a,b,i=0,num,f;
scanf("%d%d",&a,&b);
num=0;
for(i=a;b>0;i++)
{
           
           f=num+a;
            num++;
if((i%4==0&&i%100!=0)||i%400==0)
{
b--;             
                        }}
printf("%d\n",f);
}
return 0;

}

方法二:

#include<stdio.h>
int main()
{
int n,i;
scanf("%d",&n);
while(n--)
{
int a,b,i=0,num,f;
scanf("%d%d",&a,&b);
while(b!=0)
{
num=a+i;
i++;
if((num%4==0&&num%100!=0)||num%400==0)
{
b--;
}
}
printf("%d\n",num);
}
return 0;
}

An Easy Task

标签:

原文地址:http://blog.csdn.net/l15738519366/article/details/45968697

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!