码迷,mamicode.com
首页 > 其他好文 > 详细

POJ1163

时间:2015-05-25 16:40:12      阅读:98      评论:0      收藏:0      [点我收藏+]

标签:poj 算法 java

The Triangle
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 40061   Accepted: 24133

Description

7
3   8
8   1   0
2   7   4   4
4   5   2   6   5

(Figure 1)
Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.

Input

Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.

Output

Your program is to write to standard output. The highest sum is written as an integer.

Sample Input

5
7
3 8
8 1 0 
2 7 4 4
4 5 2 6 5

Sample Output

30







import java.util.Scanner;

public class Poj1163 {

	public static void main(String[] args) {

		Scanner sc = new Scanner(System.in);

		int rows = sc.nextInt();

		int[][] a = new int[rows][rows];

		// 录入数据
		for (int i = 0; i < rows; i++) {
			for (int j = 0; j <= i; j++) {
				a[i][j] = sc.nextInt();
			}
		}

		// 动态规划,获取最大值
		for (int i = rows - 2; i >= 0; i--) {
			for (int j = 0; j <= i; j++) {
				a[i][j] = Math.max(a[i + 1][j], a[i + 1][j + 1]) + a[i][j];
			}
		}

		System.out.println(a[0][0]);
	}

}


POJ1163

标签:poj 算法 java

原文地址:http://blog.csdn.net/bear_huangzhen/article/details/45967189

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!