码迷,mamicode.com
首页 > 其他好文 > 详细

POJ-1753

时间:2015-05-25 22:20:11      阅读:154      评论:0      收藏:0      [点我收藏+]

标签:

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 33298   Accepted: 14555

Description

Flip game is played on a rectangular 4x4 field with two-sided pieces placed on each of its 16 squares. One side of each piece is white and the other one is black and each piece is lying either it‘s black or white side up. Each round you flip 3 to 5 pieces, thus changing the color of their upper side from black to white and vice versa. The pieces to be flipped are chosen every round according to the following rules:
  1. Choose any one of the 16 pieces.
  2. Flip the chosen piece and also all adjacent pieces to the left, to the right, to the top, and to the bottom of the chosen piece (if there are any).

技术分享Consider the following position as an example:

bwbw
wwww
bbwb
bwwb
Here "b" denotes pieces lying their black side up and "w" denotes pieces lying their white side up. If we choose to flip the 1st piece from the 3rd row (this choice is shown at the picture), then the field will become:

bwbw
bwww
wwwb
wwwb
The goal of the game is to flip either all pieces white side up or all pieces black side up. You are to write a program that will search for the minimum number of rounds needed to achieve this goal.

Input

The input consists of 4 lines with 4 characters "w" or "b" each that denote game field position.

Output

Write to the output file a single integer number - the minimum number of rounds needed to achieve the goal of the game from the given position. If the goal is initially achieved, then write 0. If it‘s impossible to achieve the goal, then write the word "Impossible" (without quotes).

Sample Input

bwwb
bbwb
bwwb
bwww

Sample Output

4

Source

/**
          题意:给出一个矩阵‘w‘代表白,‘b’代表黑,求把矩阵变为全黑或者全白的次数最小‘
          做法:高斯消元  枚举自由变元
**/
#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <string>
#include <math.h>
#include <stdlib.h>
#include <time.h>
using namespace std;
const int MAXN = 300;
int equ,var;
int a[MAXN][MAXN]; 
int x[MAXN]; 
int free_x[MAXN];
int free_num;
int Gauss()
{
    int max_r,col,k;
    free_num = 0;
    for(k = 0, col = 0 ; k < equ && col < var ; k++, col++)
    {
        max_r = k;
        for(int i = k+1; i < equ; i++)
        {
            if(abs(a[i][col]) > abs(a[max_r][col]))
                max_r = i;
        }
        if(a[max_r][col] == 0)
        {
            k--;
            free_x[free_num++] = col;
            continue;
        }
        if(max_r != k)
        {
            for(int j = col; j < var+1; j++)
                swap(a[k][j],a[max_r][j]);
        }
        for(int i = k+1; i < equ; i++)
        {
            if(a[i][col] != 0)
            {
                for(int j = col; j < var+1; j++)
                    a[i][j] ^= a[k][j];
            }
        }
    }
    for(int i = k; i < equ; i++)
        if(a[i][col] != 0)
            return -1;
    if(k < var) return var-k;
    for(int i = var-1; i >= 0; i--)
    {
        x[i] = a[i][var];
        for(int j = i+1; j < var; j++)
            x[i] ^= (a[i][j] && x[j]);
    }
    return 0;
}
int n;
void init()
{
    memset(a,0,sizeof(a));
    memset(x,0,sizeof(x));
    equ = n*n;
    var = n*n;
    for(int i = 0; i < n; i++)
        for(int j = 0; j < n; j++)
        {
            int t = i*n+j;
            a[t][t] = 1;
            if(i > 0)a[(i-1)*n+j][t] = 1;
            if(i < n-1)a[(i+1)*n+j][t] = 1;
            if(j > 0)a[i*n+j-1][t] = 1;
            if(j < n-1)a[i*n+j+1][t] = 1;
        }
}
const int INF = 0x3f3f3f3f;
int solve()
{
    int t = Gauss();
    if(t == -1)
    {
        return INF;
    }
    else if(t == 0)
    {
        int ans = 0;
        for(int i = 0; i < n*n; i++)
            ans += x[i];
        return ans;
    }
    else
    {
        int ans = INF;
        int tot = (1<<t);
        for(int i = 0; i < tot; i++)
        {
            int cnt = 0;
            for(int j = 0; j < t; j++)
            {
                if(i&(1<<j))
                {
                    x[free_x[j]] = 1;
                    cnt++;
                }
                else x[free_x[j]] = 0;
            }
            for(int j = var-t-1; j >= 0; j--)
            {
                int idx;
                for(idx = j; idx < var; idx++)
                    if(a[j][idx])
                        break;
                x[idx] = a[j][var];
                for(int l = idx+1; l < var; l++)
                    if(a[j][l])
                        x[idx] ^= x[l];
                cnt += x[idx];
            }
            ans = min(ans,cnt);
        }
        return ans;
    }
}
char str[10][10];
int main()
{
    n = 4;
    for(int i = 0; i < 4; i++)
        scanf("%s",str[i]);
    init();
    for(int i = 0; i < 4; i++)
        for(int j = 0; j < 4; j++)
        {
            if(str[i][j] == b)a[i*4+j][16] = 0;
            else a[i*4+j][16] = 1;
        }
    int ans1 = solve();
    init();
    for(int i = 0; i < 4; i++)
        for(int j = 0; j < 4; j++)
        {
            if(str[i][j] == b)a[i*4+j][16] = 1;
            else a[i*4+j][16] = 0;
        }
    int ans2 = solve();
    if(ans1 == INF && ans2 == INF)
        printf("Impossible\n");
    else printf("%d\n",min(ans1,ans2));
    return 0;
}

 

POJ-1753

标签:

原文地址:http://www.cnblogs.com/chenyang920/p/4528860.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!