码迷,mamicode.com
首页 > 其他好文 > 详细

HDU--2017

时间:2015-05-25 22:38:00      阅读:151      评论:0      收藏:0      [点我收藏+]

标签:hdu

字符串统计

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 51785    Accepted Submission(s): 28416


Problem Description
对于给定的一个字符串,统计其中数字字符出现的次数。
 

Input
输入数据有多行,第一行是一个整数n,表示测试实例的个数,后面跟着n行,每行包括一个由字母和数字组成的字符串。
 

Output
对于每个测试实例,输出该串中数值的个数,每个输出占一行。
 

Sample Input
2 asdfasdf123123asdfasdf asdf111111111asdfasdfasdf
 

Sample Output
6 9
 

Author
lcy

#include <iostream>
#include <cstring>
#include <stdlib.h>

using namespace std;

int main()
{
	char c[100000];
	int num = 0;
	memset(c,0,100000);
	int n;
	while (cin >> n)
	{
		while (n--)
		{
			cin >> c;
			num = 0;
			int p= strlen(c);
			for (int i=0; i<p; i++)
			{
				if (c[i] >= '0' && c[i] <= '9')
					num++;
			}
			cout << num << endl;
		}
	}
	return 0;
}

另外附上discuss里面的优秀代码,以后我都会尽量附上优秀代码与我的进行一个对比。在对比之中取得进步。
#include<iostream>
#include<string>
using namespace std;
int  main()
{
	string str;
	int n;	
	cin>>n;
	while(n --)
	{	int count = 0;
		int len;
		cin>>str;
		len = str.size();
		for(int i = 0;i < len;i++)
		{
			if(str.at(i) >= '0' && str.at(i) <= '9')
			{
				count++;
			}
		}
		cout<<count<<endl;

	}
	return 0;
}


HDU--2017

标签:hdu

原文地址:http://blog.csdn.net/xiaotan1314/article/details/45972735

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!