码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 1611 The Suspects (并查集)

时间:2015-05-25 23:58:55      阅读:326      评论:0      收藏:0      [点我收藏+]

标签:

The Suspects
Time Limit: 1000MS   Memory Limit: 20000K
Total Submissions: 25130   Accepted: 12313

Description

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others. 
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP). 
Once a member in a group is a suspect, all members in the group are suspects. 
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.

Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space. 
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.

Output

For each case, output the number of suspects in one line.

Sample Input

100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0

Sample Output

4
1
1


还是模板题。
#include <iostream>
#include <cstdio>
#include <string>
#include <queue>
#include <vector>
#include <map>
#include <algorithm>
#include <cstring>
#include <cctype>
#include <cstdlib>
#include <cmath>
#include <ctime>
using    namespace    std;

const    int    SIZE = 30005;
int    FATHER[SIZE],RANK[SIZE];
int    N,K;

void    ini(int);
int    find_father(int);
void    unite(int,int);
bool    same(int,int);
int    main(void)
{
    int    num;
    int    father,child;

    while(scanf("%d%d",&N,&K) && (N || K))
    {
        ini(N);
        while(K --)
        {
            scanf("%d",&num);
            scanf("%d",&father);
            for(int i = 0;i < num - 1;i ++)
            {
                scanf("%d",&child);
                unite(father,child);
            }
        }
        printf("%d\n",RANK[find_father(0)]);
    }

    return    0;
}

void    ini(int n)
{
    for(int i = 0;i < n;i ++)
    {
        FATHER[i] = i;
        RANK[i] = 1;
    }
}

int    find_father(int n)
{
    if(FATHER[n] == n)
        return    n;
    return    FATHER[n] = find_father(FATHER[n]);
}

void    unite(int x,int y)
{
    x = find_father(x);
    y = find_father(y);

    if(x == y)
        return    ;
    if(RANK[x] < RANK[y])
    {
        FATHER[x] = y;
        RANK[y] += RANK[x];
    }
    else
    {
        FATHER[y] = x;
        RANK[x] += RANK[y];
    }
}

 

POJ 1611 The Suspects (并查集)

标签:

原文地址:http://www.cnblogs.com/xz816111/p/4529038.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!