码迷,mamicode.com
首页 > 其他好文 > 详细

VF(动态规划)

时间:2015-05-26 00:15:48      阅读:236      评论:0      收藏:0      [点我收藏+]

标签:

VF

时间限制:1000 ms  |  内存限制:65535 KB
难度:2
描述
Vasya is the beginning mathematician. He decided to make an important contribution to the science and to become famous all over the world. But how can he do that if the most interesting facts such as Pythagor’s theorem are already proved? Correct! He is to think out something his own, original. So he thought out the Theory of Vasya’s Functions. Vasya’s Functions (VF) are rather simple: the value of the Nth VF in the point S is an amount of integers from 1 to N that have the sum of digits S. You seem to be great programmers, so Vasya gave you a task to find the milliard VF value (i.e. the VF with N = 109) because Vasya himself won’t cope with the task. Can you solve the problem?
输入
There are multiple test cases.
Integer S (1 ≤ S ≤ 81).
输出
The milliard VF value in the point S.
样例输入
1
样例输出
10
描述:题意较难理解,就是小于1000000000的个位数字合为n的个数,动态规划;
#include<stdio.h>
int main(){
    int vf[10][90]={0},i,j,k,sum,s;
    
    for(int i=1;i<=9;++i)vf[1][i]=1;
    for(int i=1;i<=9;++i)for(int j=1;j<=9*i;++j)for(int k=0;k<=j&&k<=9;++k)vf[i][j]+=vf[i-1][j-k];
    while(~scanf("%d",&s)){sum=0;
    if(s==1)printf("10\n");
    else{
        for(int i=1;i<=9;++i)sum+=vf[i][s];
        printf("%d\n",sum);}
    }
    return 0;
}

VF(动态规划)

标签:

原文地址:http://www.cnblogs.com/handsomecui/p/4529281.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!