码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 2559 Largest Rectangle in a Histogram(单调栈)

时间:2015-05-26 01:40:02      阅读:770      评论:0      收藏:0      [点我收藏+]

标签:

Description

A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists of rectangles with the heights 2, 1, 4, 5, 1, 3, 3, measured in units where 1 is the width of the rectangles: 
技术分享

Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.

Input

The input contains several test cases. Each test case describes a histogram and starts with an integer n, denoting the number of rectangles it is composed of. You may assume that 1<=n<=100000. Then follow nintegers h1,...,hn, where 0<=hi<=1000000000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is 1. A zero follows the input for the last test case.

Output

For each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line.

Sample Input

7 2 1 4 5 1 3 3
4 1000 1000 1000 1000
0

Sample Output

8
4000

学习了下单调栈写法。

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<vector>
#include<string>
#include<iostream>
#include<queue>
#include<cmath>
#include<map>
#include<stack>
#include<bitset>
using namespace std;
#define REPF( i , a , b ) for ( int i = a ; i <= b ; ++ i )
#define REP( i , n ) for ( int i = 0 ; i < n ; ++ i )
#define CLEAR( a , x ) memset ( a , x , sizeof a )
typedef long long LL;
typedef pair<int,int>pil;
const int INF = 0x3f3f3f3f;
const int maxn=1e5+100;
struct node{
    int val;
    int pos;
};
stack<node>s;
int n,a[maxn];
int main()
{
    node st;
    while(~scanf("%d",&n)&&n)
    {
        REPF(i,1,n)
          scanf("%d",&a[i]);
        st.val=st.pos=0;
        s.push(st);LL ans=0;
        for(int i=1;i<=n;i++)
        {
            st.pos=i;
            while(s.top().val>a[i])
            {
                st=s.top();
                s.pop();
                LL temp=(LL)st.val*(i-st.pos);
                ans=max(ans,temp);
            }
            st.val=a[i];
            s.push(st);
        }
        while(!s.empty())
        {
            st=s.top();
            LL temp=(LL)st.val*(n-st.pos+1);
            ans=max(ans,temp);
            s.pop();
        }
        printf("%I64d\n",ans);
    }
    return 0;
}


/*

*/
以前习惯这样写。

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<vector>
#include<string>
#include<iostream>
#include<queue>
#include<cmath>
#include<map>
#include<stack>
#include<bitset>
using namespace std;
#define REPF( i , a , b ) for ( int i = a ; i <= b ; ++ i )
#define REP( i , n ) for ( int i = 0 ; i < n ; ++ i )
#define CLEAR( a , x ) memset ( a , x , sizeof a )
typedef long long LL;
typedef pair<int,int>pil;
const int INF = 0x3f3f3f3f;
const int maxn=1e5+100;
int l[maxn],r[maxn];
int n,num[maxn];
int main()
{
    while(~scanf("%d",&n)&&n)
    {
        REPF(i,1,n)
            scanf("%d",&num[i]);
        l[1]=1;
        REPF(i,2,n)
        {
            int pos=i;
            while(pos-1>=1&&num[i]<=num[pos-1])
                pos=l[pos-1];
            l[i]=pos;
        }
        r[n]=n;
        for(int i=n-1;i>=1;i--)
        {
            int pos=i;
            while(pos+1<=n&&num[i]<=num[pos+1])
                pos=r[pos+1];
            r[i]=pos;
        }
        LL ans=0;
        REPF(i,1,n)
            ans=max(ans,(LL)num[i]*(r[i]-l[i]+1));
        printf("%lld\n",ans);
    }
    return 0;
}



POJ 2559 Largest Rectangle in a Histogram(单调栈)

标签:

原文地址:http://blog.csdn.net/u013582254/article/details/45999933

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!