码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 1979 Red and Black

时间:2015-05-26 09:02:26      阅读:149      评论:0      收藏:0      [点我收藏+]

标签:

Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 25081   Accepted: 13539

Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can‘t move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

‘.‘ - a black tile
‘#‘ - a red tile
‘@‘ - a man on a black tile(appears exactly once in a data set)
The end of the input is indicated by a line consisting of two zeros.

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13

简单DFS
CODE:
#include <iostream>
#include <cstdio>
#include <cstring>
#define REP(i, s, n) for(int i = s; i <= n; i ++)
#define REP_(i, s, n) for(int i = n; i >= s; i --)
#define MAX_N 20 + 5

using namespace std;

int n, m, ans = 0;
bool map[MAX_N][MAX_N], used[MAX_N][MAX_N];
char ch;
int dx[5] = {0, -1, 0, 0, 1}, dy[5] = {0, 0, -1, 1, 0};

void dfs(int s, int t){
    if(map[s][t]) ans ++;
    REP(i, 1, 4){
        int ns = s + dx[i], nt = t + dy[i];
        if(ns >= 1 && ns <= m && nt >= 1 && nt <= n && map[ns][nt] && !used[ns][nt]){
            used[ns][nt] = 1; dfs(ns, nt); 
        }
    }
}
            
int main(){
    while(scanf("%d%d", &n, &m) != EOF){
        if(n == 0 && m == 0) break;
        memset(used, 0, sizeof(used));
        int s, t; ans = 0; getchar();
        REP(i, 1, m){
            REP(j, 1, n){ 
                cin >> ch;
                if(ch == @) {s = i, t = j; map[i][j] = 1; continue;}
                map[i][j] = (ch == . ? 1 : 0);
            }
            getchar();
        }
        
        used[s][t] = 1;
        dfs(s, t);
        printf("%d\n", ans);
    }
    return 0;
}

 


POJ 1979 Red and Black

标签:

原文地址:http://www.cnblogs.com/ALXPCUN/p/4529565.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!