码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 2782 Bin Packing

时间:2015-05-26 09:04:19      阅读:135      评论:0      收藏:0      [点我收藏+]

标签:

Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 5513   Accepted: 2495

Description

A set of n 1-dimensional items have to be packed in identical bins. All bins have exactly the same length l and each item i has length li<=l . We look for a minimal number of bins q such that
  • each bin contains at most 2 items,
  • each item is packed in one of the q bins,
  • the sum of the lengths of the items packed in a bin does not exceed l .

You are requested, given the integer values n , l , l1 , ..., ln , to compute the optimal number of bins q .

Input

The first line of the input contains the number of items n (1<=n<=105) . The second line contains one integer that corresponds to the bin length l<=10000 . We then have n lines containing one integer value that represents the length of the items.

Output

Your program has to write the minimal number of bins required to pack all items.

Sample Input

10
80
70
15
30
35
10
80
20
35
10
30

Sample Output

6

Hint

The sample instance and an optimal solution is shown in the figure below. Items are numbered from 1 to 10 according to the input order.
技术分享
 
跟《纪念品分组》一样
CODE:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#define REP(i, s, n) for(int i = s; i <= n; i ++)
#define REP_(i, s, n) for(int i = n; i >= s; i --)
#define MAX_N 100000 + 10

using namespace std;

int main(){
    int n, len, a[MAX_N];
    scanf("%d%d", &n, &len);
    REP(i, 1, n) scanf("%d", &a[i]);
    sort(a + 1, a + n + 1);
    
    int l = 1, r = n, sum = 0;
    while(l < r){
        if(a[l] + a[r] > len) r --, sum ++; 
        else l ++, r --, sum ++;
    }
    
    if(l > r) printf("%d\n", sum);
    else if(l == r) printf("%d\n", sum + 1);
        
    return 0;
}

 

POJ 2782 Bin Packing

标签:

原文地址:http://www.cnblogs.com/ALXPCUN/p/4529589.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!