码迷,mamicode.com
首页 > 其他好文 > 详细

POJ_3278_Catch That Cow

时间:2015-05-26 18:17:51      阅读:87      评论:0      收藏:0      [点我收藏+]

标签:

Catch That Cow
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 54911   Accepted: 17176

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.
题解:
宽度优先搜索bfs
代码:
#include<iostream>
#include<queue>
#include<cstring>
using namespace std;
#define N 100005
struct Node
{
    int x;
    int step;
};
queue<struct Node>q;
bool visit[N];

bool ok(int x)
{
    if(x>=0 && x<=100000)
        return 1;
    return 0;
}

int cal(int i,int x)
{
    if(i==0)
        return x+1;
    else if(i==1)
        return x-1;
    else
        return x*2;
}
void bfs(int a,int b)
{
    memset(visit,0,sizeof(visit));
    while(!q.empty())
    {
        q.pop();
    }
    Node aa;
    aa.step=1;
    aa.x=a;
    q.push(aa);
    visit[aa.x]=1;
    while(!q.empty())
    {
        Node tmp=q.front();
        q.pop();
        for(int i=0; i<3; i++)
        {
            int y=cal(i,tmp.x);
            if(ok(y)&&!visit[y])
            {
                if(y==b)
                    cout<<tmp.step<<endl;
                else
                {
                    aa.step=tmp.step+1;
                    aa.x=y;
                    q.push(aa);

                }
          visit[y]
=1; } } } } int main() { int n,k; cin>>n>>k; if(k>n) bfs(n,k); else cout<<(n-k); return 0; }

 

POJ_3278_Catch That Cow

标签:

原文地址:http://www.cnblogs.com/jasonlixuetao/p/4531101.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!