码迷,mamicode.com
首页 > 其他好文 > 详细

ACM-Sort it

时间:2015-05-27 10:09:49      阅读:120      评论:0      收藏:0      [点我收藏+]

标签:

描述
You want to processe a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. Then how many times it need.
For example, 1 2 3 5 4, we only need one operation : swap 5 and 4.
输入
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 1000); the next line contains a permutation of the n integers from 1 to n.
输出
For each case, output the minimum times need to sort it in ascending order on a single line.
样例输入
3
1 2 3
4 
4 3 2 1 
样例输出
0
6
代码:
#include<iostream>
using namespace std;
int main()
{
    int t;

    while(cin>>t)
    {
        int a[1000];
        int i,temp,count = 0;
        for(i = 0;i < t;i++)
            cin>>a[i];
        for(i= 0;i < t;i++)
            for(int j = 0;j < t-i-1;j++)
        {
            if(a[j]>a[j+1])
            {
                temp = a[j];
                a[j] = a[j+1];
                a[j+1] = temp;
                count++;
            }
        }
            cout<<count<<endl;
    }
    return 0;
}
        

ACM-Sort it

标签:

原文地址:http://blog.csdn.net/u012701023/article/details/46041871

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!