码迷,mamicode.com
首页 > 其他好文 > 详细

ACM-a letter and a number

时间:2015-05-27 10:12:24      阅读:149      评论:0      收藏:0      [点我收藏+]

标签:

描述
we define f(A) = 1, f(a) = -1, f(B) = 2, f(b) = -2, ... f(Z) = 26, f(z) = -26;
Give you a letter x and a number y , you should output the result of y+f(x).
输入
On the first line, contains a number T(0<T<=10000).then T lines follow, each line is a case.each case contains a letter x and a number y(0<=y<1000).
输出
for each case, you should the result of y+f(x) on a line
样例输入
6
R 1
P 2
G 3
r 1
p 2
g 3
样例输出
19
18
10
-17
-14
-4
代码:
#include<iostream>
 using namespace std;
 int main()
 { int k,j;
 char i;
 cin>>k;
 while(k--)
 { cin>>i>>j;
 if(i<=‘Z‘&&i>=‘A‘)
 cout<<i+j-64<<endl; 
 else if(i<=‘z‘&&i>=‘a‘)
 cout<<96-i+j<<endl;
 } 
 }        

ACM-a letter and a number

标签:

原文地址:http://blog.csdn.net/u012701023/article/details/46041745

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!