码迷,mamicode.com
首页 > 其他好文 > 详细

HDU The area

时间:2015-05-27 10:12:28      阅读:164      评论:0      收藏:0      [点我收藏+]

标签:

The area

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 28   Accepted Submission(s) : 23

Font: Times New Roman | Verdana | Georgia

Font Size:

Problem Description

Ignatius bought a land last week, but he didn‘t know the area of the land because the land is enclosed by a parabola and a straight line. The picture below shows the area. Now given all the intersectant points shows in the picture, can you tell Ignatius the area of the land?

Note: The point P1 in the picture is the vertex of the parabola.

技术分享

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains three intersectant points which shows in the picture, they are given in the order of P1, P2, P3. Each point is described by two floating-point numbers X and Y(0.0<=X,Y<=1000.0).

Output

For each test case, you should output the area of the land, the result should be rounded to 2 decimal places.

Sample Input

2
5.000000 5.000000
0.000000 0.000000
10.000000 0.000000
10.000000 10.000000
1.000000 1.000000
14.000000 8.222222

Sample Output

33.33
40.69
求积分没什么好说的。
AC代码:
#include <iostream>
#include <cstdio>
#include <cmath>
using namespace std;
int main(){
   int n;
   float x1,x2,x3,y1,y2,y3,area;
   scanf("%d",&n);
   while(n--){
    scanf("%f%f%f%f%f%f",&x1,&y1,&x2,&y2,&x3,&y3);
    area=(y2-y1)*pow(x3-x1,3)/(3*pow(x2-x1,2))-(y2-y1)*(x2-x1)/3+(y1-y2)*(x3-x2)-(y3-y2)*(x3-x2)/2;
    printf("%.2f\n",area);
   }
    return 0;
}

运行结果:
技术分享

HDU The area

标签:

原文地址:http://blog.csdn.net/zp___waj/article/details/46041665

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!