码迷,mamicode.com
首页 > 其他好文 > 详细

G - Power Strings POJ 2406 (字符串的周期)

时间:2015-05-27 23:03:43      阅读:255      评论:0      收藏:0      [点我收藏+]

标签:


G - Power Strings
Time Limit:3000MS Memory Limit:65536KB 64bit IO Format:%I64d & %I64u
Submit Status Practice POJ 2406

Description
Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input
Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output
For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

1.直接暴力枚举

#include<cstdio>
#include<algorithm>
#include<cmath>
#include<cstdlib>
#include<cstring>
#include<vector>
using namespace std;
const int maxn=1000005;
typedef long long LL;
char s[maxn];
int main(){
    int T;
    //freopen("Text//in.txt","r",stdin);
    while(~scanf("%s",s)&&s[0]!='.'){
        int len=strlen(s);
        for(int i=1;i<=len;i++)if(len%i==0){
            int ok=1;
            for(int j=i;j<len;j++){
                if(s[j]!=s[j%i]){
                    ok=0;break;
                }
            }
            if(ok){
                printf("%d\n",len/i);break;
            }
        }
    }
    return 0;
}



2.kmp算法 i-next[i]:表示已i结尾的前缀的循环节的长度

#include<cstdio>
#include<algorithm>
#include<cmath>
#include<cstdlib>
#include<cstring>
#include<vector>
using namespace std;
const int maxn=1000005;
typedef long long LL;
char s[maxn];
int next[maxn];
void getnext(char*s){
    int len=strlen(s);
    int i=0,j=-1;
    next[0]=-1;
    while(i<len){
        if(j==-1||s[i]==s[j]){
             next[++i]=++j;
        }
        else
            j=next[j];
    }
}
int main(){
    int T;
    //freopen("Text//in.txt","r",stdin);
    while(~scanf("%s",s)&&s[0]!='.'){
        int len=strlen(s);
        getnext(s);
        int k=len-next[len];
        if(len%k==0){
            printf("%d\n",len/k);
        }
        else
            printf("1\n");
    }
    return 0;
}




G - Power Strings POJ 2406 (字符串的周期)

标签:

原文地址:http://blog.csdn.net/u013167299/article/details/46050405

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!